Рекомендуемые сообщения

aleksss454    2

Добрый день, устанавливаю на сервер для создания нового сайта ocStore 2.3.0.2, установка не начинается требует PHP5.4 при переходе на домен выдает PHP5.4+ Required.

На сервере установлено и настроено РНР 5.3.3 работает через апач, также на сервере нормально работает несколько сайтов, в требованиях  к  2.3.0.2 прописано https://myopencart.com/downloads РНР 5.3+ (1.5.x как минимум 5.2+) или эти данные устарели???

Права на файлы проверял 755 поменял на 777

Подскажите возможно завести ocStore 2.3.0.2 с РНР 5,3.3??? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
pashast    377

Устарели

5.4 минимаальное требование

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
aleksss454    2

Спасибо за ответ!!!

Если запускать  РНР 5.4 через  режимы работы php CGI как думаете работать будет медленнее.?

Изменено пользователем aleksss454

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
pashast    377

Вряд ли вы увидите на глаз разницу в скорости. Разве что на высоконагруженом сайта будет видна разница.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Otvet    426

Вряд ли вы увидите на глаз разницу в скорости. Разве что на высоконагруженом сайта будет видна разница.

на фоне тормозного mysql может

а на оптимизированном опенкарт может и в несколько раз отличаться

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
aleksss454    2

Очень жаль только оптимизация на сервера была с РНР 5.3.3 , хз как сделать что бы работало нормально сайт планируется под 50 000 товаров.

Наверное придется опять оптимизировать или как нибудь прикрутить рнр 5.4. к апач.

Если кто знает как это сделать на панели ispmanager 5 цент 6 без переустановки сервера буду благодарен за подсказки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Otvet    426

не надо 5.4

5.6 или 7

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
pashast    377

не надо 5.4

5.6 или 7

На php 7 могут быть проблемы с некоторыми модулями

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
shef27    0

а можете подсказать на каком локальном хосте можно по тестировать сей магазин

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
neonox    17

openserver

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
shef27    0

спасибо 

 

openserver

спасибо

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый день , подскажите для чайника , та же проблема ...при переходе на домен выдает PHP5.4+ Required. хостинг reg.ru , админ панель ispmgr. куда дальше тыкать ) чтоб установить движок ? за ранее спасибо

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нашел с горем пополам ,5.4 был отключен. отключит 7 включил 5.4... может кому пригодится смотрите скрин)

Screenshot_6.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
korolev9999    0

Здравствуйте! Подскажите, где именно нужно отключить 7 и включить 5.4? 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
qwert5005    4

korolev9999 Если хостинг Бегет, то заходите в меню "сайты" там на против домена (справа ближе к краю панели) будут пункты HTTP  PHP и отвязка домена, так вот тыкаете на кнопку PHP и меняете там версию на нужную. На других хостингах тоже должны быть меню с похожими настройками. P/S выбрал версию  PHP 5.6 все равно глюк не пропал (видно страница в памяти браузера засела),  выбрал версию 7.0 запуск пошел, но я снова поставил 5.6. Как настрою магазин снова выберу 7.0 и посмотрю как что будет работать,  PHP 7.0 конечно лучше, но надо на старой сначала все настроить и уже при идеальной работе магазина экспериментировать с новой версией PHP

Изменено пользователем qwert5005

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
jekyman83    3

Панель Ispmanager 5, так и не получается запустить установку, все версии php запускал, перепроверял, ostore2.3 ставлю на поддомен, все равно ошибка php 5.4+ required.

Куда копать дальше не знаю!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, jekyman83 сказал:

Куда копать дальше не знаю!

в сторону хостера

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Похожий контент

    • От cleargoal
      Приветствую сообщество!
      2 месяца назад установил себе ocstore 2.1.0.2.1 по совету фрилансера, он сказал, что это самая стабильная версия. После этого пришел сюда на форум, вижу, что анонсирована 2.3.х.
      Прошу совет: оставаться на имеющейся версии или имеет смысл перейти на более новую? 
      Ну, и аргументы в пользу вашего совета, плз.
       
      Всем благодарен!
    • От vlad37
      Здравствуйте, помогите убрать закладки и сравнение полностью с сайта http://vesta-dveri.ru . Версия ocStore 2.1.0.2.1.
    • От maggot
      Добрый день.
      Выполнила миграцию базы с опенкарта 1.5.6.4 на окстор 2.3.0.2. Привела все таблицы вручную в соответственное состояние и все данные перенсены с заказами, поккупателями, опциями, атрибутами, опциями, товарами, категориями, url-alias и т.д.
      Все отлично, все работает, Default ЧПУ работает. Включаю СеоПро:
      Warning: fread(): Length parameter must be greater than 0 in /home/margot/two.alfa-market.com.ua/system/library/cache/file.php on line 32
       
      Хостинг ВПС. В запасе еще более 11-ти Гб.
      Содержание .htaccess
      # 1.To use URL Alias you need to be running apache with mod_rewrite enabled. # 2. In your opencart directory rename htaccess.txt to .htaccess. # For any support issues please visit: http://www.opencart.com Options +FollowSymlinks # Prevent Directoy listing Options -Indexes # Prevent Direct Access to files <FilesMatch "\.(tpl|ini|log)"> Order deny,allow Deny from all </FilesMatch> # SEO URL Settings RewriteEngine On # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ RewriteBase / RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L] RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L] RewriteRule ^download/(.*) /index.php?route=error/not_found [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css) RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA] ### Additional Settings that may need to be enabled for some servers ### Uncomment the commands by removing the # sign in front of it. ### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that. # 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it: # php_flag register_globals off # 2. If your cart has magic quotes enabled, This may work to disable it: # php_flag magic_quotes_gpc Off # 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try # php_value upload_max_filesize 999M # 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields # php_value post_max_size 999M # 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields # php_value max_execution_time 200 # 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields # php_value max_input_time 200 # 7. disable open_basedir limitations # php_admin_value open_basedir none Бьюсь уже сутки. В гугле ничего.
    • От pixel88
      Устанавливаю все как здесь https://ocstore.com/news/ustanovka-ocstore-na-hosting-cpanel/ , но после первичной установки не пускает в админку( при вводе ничего не происходит, просто страница обновляется), и куча ошибок в самом сайте. Пример ниже. Хостинг  fozzy, админка cpanel, версия ocstore 2.3.0.2.3 В чем может быть проблема? 

    • От DarthOlolo
      Добрый день, понимаю, что вопрос извращенный и туповатый, но всё же - можно ли нестандартный шаблон в ocstore 2.3.0.2.3 сделать по умолчанию, путем переименований файлов и путей в контроллерах? Изначально был default, поставил буквально сразу же после установки ocstore шаблон next_default, настроил под себя и начал дальше настраивать движок под собственные нужды, чем больше разбирался и пробовал устанавливать различные модули тем сильнее начинало парить то, что все они настроены как раз под шаблон по умолчанию - default и приходилось лазить и перименовывать папки в инсталах.
      Можно ли существующих next_default сделать основным с переименовываниями, либо еще сумасшедшая идея была заменить все файлы в шаблонах или переходить на default и его переделывать под то, что мне нужно? Подскажите, пожалуйста, как лучше решить эту ситуацию?
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу