Andronn

Не удается обновить Опенкарт.

12 сообщений в этой теме

Добрый день.

Установил софт, при первом запуске вызывается обновление. Проходит  9 из 9, поздравляет с обновлением и дальше ничего не происходит. При нажатии кнопки продолжить - снова обновляется (делает то же самое) и так много раз.

Скажите пожалуйста что можно сделать чтобы это исправить.

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах
Скажите пожалуйста что можно сделать чтобы это исправить.

 

Уточнить у автора неведомого  софта...

1

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Уточнить у автора неведомого  софта...

Отличный совет. Опишу проблему подробнее. С сайта, к которому привязан этот форум, я скачал последнюю рус. версию ОсСторе Установил ее на хостинг сверяясь с несколькими инструкциями, создал БД, админ и прочее. Переименовал нужные файлы. После установки осСторе поздравил меня с установкой. При первом запуске он захотел обновиться, при нажатии кнопки Продолжить установились патчи (9 из 9), появилось поздравление о завершении обновления, после чего при соответствующем нажатии кнопки Продолжить, происходит очередное то же самое обновление. И так много раз. К пункту 2 из 2 обновление не переходит. Никаких других кнопок кроме Продолжить (если они должны быть) не появляется. Только выбор языка и эта.  Был еще текст о чистке куки и предложение сообщить о проблемах с обновлением. Внизу страницы ссылки на сайт и этот форум.

 

А теперь вопрос знатокам.  Как это исправить? Дать возможность обновиться и работать дальше. Заранее спасибо за конструктивній совет.

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Какой вопрос-такой ответ.

 

Очень много букофф а самого важного нет. Установить это одно,а обновить совсем иное.И если не указана версия с которой идёт обновление и как именно ,то какие могут быть советы?

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Какой вопрос-такой ответ.

 

Очень много букофф а самого важного нет. Установить это одно,а обновить совсем иное.И если не указана версия с которой идёт обновление и как именно ,то какие могут быть советы?

Судя по сайту последняя версия которую я скачал называется 

ocStore 2.3.0.2. Русифицированный OpenCart 2

 

Про то как обновлялось - не скажу. Установил, появилось 2 кнопки - смотреть витрину или администрирование, выбрал смотреть витрину. Предложило обновиться без опции отказа. Далее пошло бесконечное обновление.

Изменено пользователем Andronn
0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну уже ближе..но опять хоть клещи вынимай.....

 

Речь об обновлении,так с какой версии идёт обновление?

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну уже ближе..но опять хоть клещи вынимай.....

 

Речь об обновлении,так с какой версии идёт обновление?

С этой как я понимаю. Только скачал поставил и еще ни разу не запускал. Это была собственно и первая попытка запуска после установки. Все это происходило вчера.

Как по другому посмотреть версию из неоконченного обновления я не вижу.

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Толи лыжи не едут......

 

И так.У меня есть старенький магазин,версии эдак 1.4.И вот решил я ОБНОВИТСЯ до 2.3.Прихожу на форум и задаю вопрос " Как мне обновить движок с 1.4 до 2.3...."

 

Вот это ОБНОВЛЕНИЕ.

 

А то что выше написано куда то пальцем в небо и больше смахивает на обычную установку опенкарт....

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Том, возможно клещи не понадобятся  :-) 

 

Andronn, вы либо изначально выбрали вариант не установки, а обновления

 

либо, что более вероятно, после установки движка, НЕ удалив папку install снова перешли по ссылке site/install

в этом случае движок автоматом предлагает обновление

 

на которое жмакать не нужно было

сносите все и ставьте с нуля

 

про удаление папки install после установки - не зря пишется красным шрифтом на завершающем этапе ;)

1

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

AlexDW, инстал вроде удалял, точно помню. Впрочем, сделал как вы советовали - снес все и поставил заново. Помогло. Не знаю или я где ступил или глюк хостинга (там на днях что-то было с выбором версии РнР, потом само все заработало), но сейчас все как надо. Спасибо за совет.

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Возникла проблема при установке шаблона. 

Заменять нужно только папку catalog или все остальные тоже, которые идут вместе с шаблоном?

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

с проблемами по установке модулей/шаблонов - нужно обращаться к их авторам

исключения составляют бесплатные решения - но тогда на них нужно давать ссылку при описании проблем

0

Поделиться этим сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или авторизуйтесь, чтобы оставить комментарий

Комментарии могут оставлять только зарегистрированные пользователи

Создать аккаунт

Зарегистрировать новый аккаунт в нашем сообществе. Это несложно!


Зарегистрировать новый аккаунт

Войти

Есть аккаунт? Войти.


Войти

  • Недавно просматривали   0 пользователей

    Ни один зарегистрированный пользователь не просматривает эту страницу.