pasikadima

ocStore 2.1.0.2.1 проблема php.ini

Рекомендуемые сообщения

pasikadima    0

Добрый вечер! Помогите пожалуйста в решении проблемы! Установил ocstore на demwer, пощупал, посмотрел что да как и приступил к настройке магазина. Первый модуль который я решил поставить это экспорт/импорт xlsx, дабы посмотреть какой прайс нужно готовить. Но сразу же столкнулся с проблемой установки через (Установщик дополнений OCMOD). Файл .ocmod.zip, как пишут на просторах интернета он должен без проблем становиться.

Проблема заключается в следующем: сразу после начала установки модуля вылетает ошибка о большом размере файла в файле php.ini, наступал на те же грабли в prestashop и сразу помчался редактировать php.ini. Но когда я туда заглянул та не было ни одной строки о размере загружаемого файла, только upload_max_filesize = 999М. На форуме нашел тему что нужно отредактировать если не ошибаюсь 5 строк. но у меня 4 из них нет в файле. пробовал дописывать вручную - никакого результата. Что делать да как быть? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
pantagruel964    219

php-zip установлен?

 

Вообще не трогайте денвер, дайте уже старику на пенсию уйти.

 

Установите Open Server и не мучайтесь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SiteMix    145

Установил ocstore на demwer

...

Проблема заключается в следующем: сразу после начала установки модуля вылетает ошибка о большом размере файла в файле php.ini, наступал на те же грабли в prestashop и сразу помчался редактировать php.ini. Но когда я туда заглянул та не было ни одной строки о размере загружаемого файла, только upload_max_filesize = 999М. На форуме нашел тему что нужно отредактировать если не ошибаюсь 5 строк. но у меня 4 из них нет в файле. пробовал дописывать вручную - никакого результата. Что делать да как быть?

 

Если я правильно понял, то ты пытаешься редактировать php.ini лежащий в корне сайта. А нужно править файл Денвера. Находится он по пути: \WebServers\usr\local\php5\php.ini

 

Кстати, на OcStore следует использовать адаптированную для него версию экспорт/импорт xlsx - Экспорт-импорт export import .xlsx для OCSTORE 2.x так как в OcStore есть дополнительные поля.

 

И ещё. Для установки OCMOD-модулей нужно наличие ftp, которого на Денвере нет, поэтому нужно либо ставить модули вручную, либо ставить QuickFix, который позволяет обойти эту проблему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
throwzenon    2

По моему денвер не обновляется несколько лет, лучше уж Опенсервер, там обычно все актуальные настройки уже сделаны

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу