Перейти к содержанию

Рекомендуемые сообщения

Подскажите, пожалуйста, есть проблема...   Для интеграции 1С с сайтом в файле htaccess в корне сайта я добавил такую строку #RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization},L] 
Со знаком # в начале строки сайт работает нормально, но нет подключения 1С к сайту.
Без знака # есть подключение 1С к сайту, но некоторые кнопки сайта не работают, а именно отображается 

Not Found

The requested URL /kreatin/ was not found on this server.

Заранее благодарен за помощь.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

знак # означает комментарий, т.е. то что за ним игнорируется

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

знак # означает комментарий, т.е. то что за ним игнорируется

И как же быть в таком случае?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

приведите целиком htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

приведите целиком htaccess

А как сюда прикрутить файл?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

код файла под спойлером выложите

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

код файла под спойлером выложите

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 
 
# 2. In your opencart directory rename htaccess.txt to .htaccess.
 
# For any support issues please visit: http://www.opencart.com
 
Options +FollowSymlinks
 
# Prevent Directoy listing 
Options -Indexes
 
# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>
 
# SEO URL Settings
RewriteEngine On
#Added 30.04.2016
#RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization},L]
 
 
 
 # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 
 
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
 
RewriteCond %{HTTP_HOST} ^www\.(.*) [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
 
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\ HTTP/
RewriteRule ^index\.html$ / [R=301,L]
 
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ / [R=301,L]
 
RewriteCond %{QUERY_STRING} ^route=common/home$
RewriteCond %{REQUEST_METHOD} !^POST$
RewriteRule ^index\.php$ http://%{HTTP_HOST}? [R=301,L]
 
### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.
 
# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off
 
# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off
 
# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M
 
# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M
 
# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200
 
# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200
 
# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

строку нужно добавлять после строки RewriteBase /

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

строку нужно добавлять после строки RewriteBase /

Сделал вот так:

 # If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 
 
RewriteBase /
#RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization},L]
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
 
Со знаком # сайт нормально работает, но нет соединения 1С, без знака # на сайте ошибка, но есть соединение 1С к сайту. (( 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

без знака # на сайте ошибка,

 

 

Какая?

 

 

Поэтому коннектор нужно вынести в отдельную директорию и там прописать эту строку...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

без знака # на сайте ошибка,

 

 

Какая?

 

 

Поэтому коннектор нужно вынести в отдельную директорию и там прописать эту строку...

Ошибка такая:

Not Found

The requested URL /perchatki-basic-ps-2100-power-system was not found on this server.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

без знака # на сайте ошибка,

 

 

Какая?

 

 

Поэтому коннектор нужно вынести в отдельную директорию и там прописать эту строку...

В какую директорию вынести и в каком файле прописать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а попробуйте убрать флаг L

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а попробуйте убрать флаг L

Попробовал. Без флага L и без знака # сайт вообще не работает. Выдает ошибку:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@ironpower.com.ua and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробовал. Без флага L

 

Как пробовал?

 

# - это комментарий, и потому оно работает, потому что это правило не работает

 

А что вы дальше делаете - мы не видим.

 

После двух трех подобных вопросов я сразу говорю - наймите исполнителя.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Возможно ли заблокировать доступ к сайту с определенных браузеров?

Пробовал запретить вход с Firefox таким конфигом

RewriteEngine On
RewriteCond %{HTTP_USER_AGENT} ^Mozilla* [NC,OR]
RewriteCond %{HTTP_USER_AGENT} ^Firefox* [NC]
RewriteRule ^login.php$ /111.html
 
Но почему-то редирект происходит со всех браузеров, например Opera и Chrom  на 111.html

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробовал. Без флага L

 

Как пробовал?

 

# - это комментарий, и потому оно работает, потому что это правило не работает

 

А что вы дальше делаете - мы не видим.

 

После двух трех подобных вопросов я сразу говорю - наймите исполнителя.

Убрал флаг L, сохранил и попробовал....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×