Перейти к содержанию
Sunrise23

Ошибка при установке темы в baner.tpl и loader.php

Рекомендуемые сообщения

Здравствуйте, пытаюсь установить данный шаблон - тыц, но при его включении появляется ошибка 

Notice: Error: Could not load template /home/plastic/el-plastic.ru/catalog/view/theme/default/template/common/baner.tpl! in /home/plastic/el-plastic.ru/system/engine/loader.php on line 86

Причем такая ошибка не только в данном шаблоне, но и во многих других. 
Делать сайты только-только начал, учусь потихоньку, поэтому надеюсь на вашу помощь  :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

файла

/home/plastic/el-plastic.ru/catalog/view/theme/default/template/common/baner.tpl

нету.

 

ищите куда дели

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

файла

/home/plastic/el-plastic.ru/catalog/view/theme/default/template/common/baner.tpl

нету.

 

ищите куда дели

в архиве с темой его не было... А если вставить этот файл из другой темы? или не пройдет фишка? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у автора спрашивайте

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

..Причем такая ошибка не только в данном шаблоне, но и во многих других.

 

catalog/view/theme/default/template/common/baner.tpl - это уже скорей ваше художество, вероятно что-то намудрили с установкой модулей

 

автору бесплатной темы выносить мозг не нужно, он и так поди проклинает день когда ее выложил :ugeek:

 

переустановите сайт с нуля, изучайте документацию

и не ставьте все подряд, перед установкой внимательно читайте инструкции

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Там весь "шаблон" состоит из картинок, одного файла CSS и осмода, прописывающего этот файл в хедер + врапер для body:

<?xml version="1.0" encoding="utf-8"?>
<modification>
  <name>Dark Velvet Template by GrandCMS.com</name>
  <version>1.0</version>
  <author>GrandCMS.com</author>
  <link>http://www.grandcms.com</link>
  <code>darkvelvet_ocmod</code>
  <file path="catalog/view/theme/default/template/common/header.tpl">
    <operation>
      <search><![CDATA[<link href="catalog/view/theme/default/stylesheet/stylesheet.css" rel="stylesheet">]]></search>
      <add position="replace"><![CDATA[<link href="catalog/view/theme/dark_velvet/stylesheet/stylesheet.css" rel="stylesheet">]]></add>
    </operation>
    <operation>
      <search><![CDATA[<body class="<?php echo $class; ?>">]]></search>
      <add position="replace"><![CDATA[<body style="background-color: #13181e;" class="<?php echo $class; ?>">
      <div class="body_wrap">]]></add>
    </operation>
  </file>
  <file path="catalog/view/theme/default/template/common/footer.tpl">
    <operation>
      <search><![CDATA[</body></html>]]></search>
      <add position="before"><![CDATA[</div><!-- body_wrap -->]]></add>
    </operation>
  </file>
</modification>

Больше в нем ничего нет. Вызывать такую ошибку он не может.

Скорее всего, это последствия ваших экспериментов с другими шаблонами - шаблон изменил код, шаблон удалили, а код кривой так и остался.

Ставьте чистый ОС.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×