max1985

Обновление ocStore 1.5.4.1 до последней версии

Рекомендуемые сообщения

max1985    2

Подскажите пожалуйста где можно взять инструкция по обновлению ocStore 1.5.4.1 до последней версии? Раньше вроде вместе с дистрибутивом шел файл с описанием, сейчас его нет. И вообще это реально сделать?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
YaSerg    0

Присоединяюсь к вопросу. У меня ocStore 1.5.5.1.1 с VQMod 2.0.

Сделал бэкап public_htm и БД, но я так понимаю установка новой версии магазина ocStore и обновления БД не достаточно.

Как обновить VQMod?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 094

Смотря до какой версии обновляться.Если выше 2.0  там vqmod не нужен.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
max1985    2

Сделал так: Установил чистую сборку, а потом переносил все вручную, часть через модуль Экспорт / Импорт, часть через Экспорт / Импорт баз. VQmod пока не трогал, буду все модули с нуля ставить...

 

Не пойму почему не сделают нормальные обновления, чтоб без проблем можно было обновится... Например как в Joomla!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 094
часть через модуль Экспорт / Импорт, часть через Экспорт / Импорт баз

 

Модуль не перенесёт заказы и покупателей к примеру(не говоря уже о статьях и описаниях категорий).

Импорт из базы в базу ....так они имеют различия эти версии.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
max1985    2

имеют различия, но не критичные это все решается... например в покупателях и группах покупателей вообще разницы не было. Заказы вообще не трогал они мне не нужны были... 

категории с описаниями без проблем перенеслись через модуль... Единственная проблема возникла с фотками, в новой версии сменилась папка с ними и не отображаются файлы в названии которых есть пробел или русские буквы (и то это решилось очень быстро). 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
prochet    12

Я вот думаю, стоит ли вобще переходить на 2 версию. Сайт рабочий, шаблон адаптивный. Но вот смущают модули, вдруг авторы откажутся поддерживать версии для 1.5

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
samulet    2

Друзья, правильно ли я понимаю, что никто не знает ответа на вопрос

 

 

где можно взять инструкция по обновлению ocStore 1.5.4.1 до последней версии

?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 094

А если их нет?Не существует общего для всех удобного способа..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
samulet    2

Мне бы хоть какой-н

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 094

По-таблично переносить данные в базу.Сверять таблицы с "чистым " движком этой версии....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    1 021

 

Но вот смущают модули, вдруг авторы откажутся поддерживать версии для 1.5

хе.. Если оно не ломается, то зачем вам поддержка?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
whidy1    0

Ребята, помогите, пожалуйста. я в этом деле совсем профан, но так случилось сделала сайт. Сейчас обновляю до новой версии а мне выдает такую ошибку : Error Code(0): Error: Unknown column 'code' in 'field list'

Error No: 1054
Error in: /home/slushpla/public_html/install/model/upgrade/1002.php line 8
INSERT INTO `oc_setting` SET `key` = 'config_product_limit', `value` = '20', `code` = 'config', `store_id` = 0 in /home/slushpla/public_html/system/library/db/mysql.php on line 54

 

Что делать???

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    1 021

Наймите специалиста

Иначе, вам нужно пройти минимальные курсы обучения sql и ЯП (в частности php)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
whidy1    0

Наймите специалиста

Иначе, вам нужно пройти минимальные курсы обучения sql и ЯП (в частности php)

 

 

Я бы наняла, только где его взять?

 

На сколько я поняла мне нужно добавить колонку "code"

 

Файл в котором возникла ошибка я нашла, и редактировать его я могу с помощью редактора кодов.

Если бы мне только написали что нужно прописать... и в каком из двух указанных файлов:

home/slushpla/public_html/install/model/upgrade/1002.php line 8

/home/slushpla/public_html/system/library/db/mysql.php on line 54

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 094

Вы в корне не верно обновляете движок.И это не ошибка ,а то что предшествовало процессу обновления.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу