Condorious

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data OK

Рекомендуемые сообщения

Condorious    7

Коллеги, добрый вечер.

 

При развёртывании ocStore 2.1.0.2 на VDS ловятся ошибки json на главной странице админки:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

k{"":{"total":"3","amount":"4 230.00 \u0440."}}

А под ней:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

k{"order":{"label":"\u0417\u0430\u043a\u0430\u0437\u043e\u0432","data":[[1,0],[2,0],[3,0],[4,0],[5,0],[6,0],[7,0],[8,0],[9,0],[10,0],[11,0],[12,0],[13,0],[14,0],[15,0],[16,0],[17,0],[18,0],[19,0],[20,0],[21,0],[22,0],[23,0],[24,0],[25,0],[26,0],[27,0],[28,0],[29,0],[30,0],[31,0]]},"customer":{"label":"\u041f\u043e\u043a\u0443\u043f\u0430\u0442\u0435\u043b\u0435\u0439","data":[[1,0],[2,0],[3,0],[4,0],[5,0],[6,0],[7,0],[8,0],[9,0],[10,0],[11,0],[12,0],[13,0],[14,0],[15,0],[16,0],[17,0],[18,0],[19,0],[20,0],[21,0],[22,0],[23,0],[24,0],[25,0],[26,0],[27,0],[28,0],[29,0],[30,0],[31,0]]},"xaxis":[["1","01"],["2","02"],["3","03"],["4","04"],["5","05"],["6","06"],["7","07"],["8","08"],["9","09"],["10","10"],["11","11"],["12","12"],["13","13"],["14","14"],["15","15"],["16","16"],["17","17"],["18","18"],["19","19"],["20","20"],["21","21"],["22","22"],["23","23"],["24","24"],["25","25"],["26","26"],["27","27"],["28","28"],["29","29"],["30","30"],["31","31"]]}

Карта со статистикой продаж не отображается.

 

Локально всё работает, на обычном shared-хостинге тоже.

Перепробовал образы Debian 7, 8, Ubuntu-sever (у меня локально используется Kubuntu 14.04, всё работает) с предустановленным LAMP, ставил и настраивал с нуля LAMP в Debian 8, никакого результата.

 

Куча подобных тем в буржуйском интернете, перегенерация api пользователя проблему не решает.

 

Так же при выдаче сайта и админки, перед выводом вылезает латинская "k":

k<!DOCTYPE html>
<html dir="ltr" lang="ru">
<head>
<meta charset="UTF-8" />
<title>Панель управления</title>

Вообще не понимаю куда копать, уже VDS раз 5-6 за день переустанавливал и по разному конфигурировал.

Кто-то встречался с подобной проблемой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Condorious    7

Олень ли я?

Естественно олень!

Латинская "k" появилась из-за того, что когда я на VDS правил конфиг, я удалял всё в редакторе nano, удаление построчно производится комбинацией CTRL+K, вот так буква "k" и затесалась в конфиг админки из-за невнимательности.

После удаления и json стал правильные ответы выдавать, так как при выводе страниц в админке не мешается никакой мусор.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу