Jump to content

Recommended Posts

Буду короток. Был магазин на веб ассист, Установили чистую open Cart, шаблон все настроили, сайт работает исправно , претензий нет.

Когда понадобилось ввести функцию оплаты банк. картами, установили сертификат безопасности SSL.

 

Решили не заморачиваться с установкой только на личный кабинет, поставили на переадресацию с http  на  https весь сайт. Все встало, все работает, отписался хостеру чтобы на всякий случай протестил со своей стороны. пришел ответ...

 

При настройке перенаправления с http на https возникает циклическая переадресация, вероятно, непосредственно в коде сайта настроена 
переадресация, в результате которой возникает подобная ошибка. В данном случае рекомендуем Вам обратиться ка разработчикам Вашего сайта, 
так как Ваш сайт не использует распространенную cms, мы не можем Вам дать точного ответа как именно на Вашем сайте реализовано данное 
перенаправление.

 

Сталкивался кто то с такой проблемой.Как её решить?

Всем заранее спасибо.

Share this post


Link to post
Share on other sites

Вы что бы ответ получить,для начала опишите ,как именно вы подключали сертификат.Потому как там действий то минимум....

Share this post


Link to post
Share on other sites

глянуть .htaccess и конфиги заодно

Share this post


Link to post
Share on other sites

Так извиняйте, по порядку...

Сертификат я не ставил, этим занимались хостеры, тут действий и впрямь минимум..

 

далее наша переписка , вернее их ответ  выглядели так..

 

В ходе анализа, мы обнаружили встроенную переадресацию на страницах передачи конфиденциальной информации(корзина и т.д.). Данная 
переадресация может быть причиной циклического перенаправления на сайте, при попытке настройки перенаправления сайта с http на https.

 

позже..

 

 

К сожалению, так как мы не являемся разработчиками данной cms, мы не

> можем точно утверждать действительно ли данная данная переадресация
> >влияет на появление ошибки циклической переадресации. Вы можете
> использовать данную встроенную переадресацию и настроить зашифрованное
> >соединение только для страниц, где ведется передача конфиденциальных
> данных.
> >Либо связаться с разработчиками данной cms: 

Share this post


Link to post
Share on other sites

Откройте ваши конфиги(  config.php   ) , их два один в корневой папке другой в папке admin

 

замените там  http на https 

 

во многих мануалах пишут что менять это нужно только  в значении 

 

// HTTPS
define('HTTPS_SERVER', 'https://вашсайт.ru/');
 
но я рекомендую заменить все значения.
 
потом заходим в админку Система-Настройки вкладка Сервер и там включаем 
 
Использовать SSL:

в принципе всё.

Share this post


Link to post
Share on other sites

В конфиге у меня сейчас следущее..

 

// HTTP
define('HTTP_SERVER', 'https://мой сайт/');
 
// HTTPS
define('HTTPS_SERVER', 'https://мой сайт/');
 
Везде нужно заменить?

Share this post


Link to post
Share on other sites

Верху это файл из конфига корня....

ниже конфиг из админа

 

<?php
// HTTP
define('HTTP_SERVER', 'http://мой сайт/admin/');
define('HTTP_CATALOG', 'http://мой сайт/');
 
// HTTPS
define('HTTPS_SERVER', 'http://мой сайт/admin/');
define('HTTPS_CATALOG', 'http://мой сайт/');

Share this post


Link to post
Share on other sites

Вы же можете прочесть то что уже было написано? 

Share this post


Link to post
Share on other sites

Спасибо за предыдущий ответ, но сейчас то можно было просто уточнить. я не программист, и плохо во всем разбираюсь, только учусь, потому и задал тут вопрос.

Share this post


Link to post
Share on other sites

Большое спасибо, разобрался, все настроил, все работает.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • By hegst
      Здравствуйте, ув. вебмастера. Нужен совет или подсказка. Что делать если после подключения HTTPS пртокола, сайт пошел криво, слетели все контейнеры, банеры, фильтры...понимаю, переход на сертификат во многих случаях безболезненно происходит, но что делать когда интернет-магазину жизненно важно использовать https а сайт написан и поддерживает http/ У кого-то была такая проблема, как решать?
    • By budulev
      Доброй ночи) Гуру опенкарта!
       
      Пришло письмо на почту от КОНТОРЫ "ХЭ" о том, что (дословно) :
       
      Поэтому есть пара вопросов: 
      Действительно все так? Проблематично ли поставить ssl сертификат на опенкарт 1.5.5.1? (читал форум как понял сплошные танцы с бубном)  
    • By orange13
      Доброго времени суток! Обращаюсь к коллективному разуму т.к. самостоятельные попытки найти решение завершились провалом. Итак суть проблемы:
      версия ocstore 1.5.5.1.2
      Поставил сертификат ssl - установка произведена специалистами хостинга.
      Отредактировал файлы конфигурации root/config.php и root/admin/config.php следующим образом:
      root/admin/config.php
      // HTTP
      define('HTTP_SERVER', 'http://site.ru/admin/');
      define('HTTP_CATALOG', 'http://site.ru/');
      define('HTTP_IMAGE', 'http://site.ru/image/');

      // HTTPS
      define('HTTPS_SERVER', 'https://site.ru/admin/'); - в этой строке дописал https вместо http
      define('HTTPS_CATALOG', 'https://site.ru/'); в этой строке дописал https вместо http
      define('HTTPS_IMAGE', 'https://site.ru/image/'); в этой строке дописал https вместо http


      root/config.php
      // HTTP
      define('HTTP_SERVER', 'http://site.ru/');
      define('HTTP_IMAGE', 'http://site.ru/image/');
      define('HTTP_ADMIN', 'http://site.ru/admin/');

      // HTTPS
      define('HTTPS_SERVER', 'https://site.ru/');в этой строке дописал https вместо http
      define('HTTPS_IMAGE', 'https://site.ru/image/');в этой строке дописал https вместо http
       
      в админ панели cms включаю ssl
      по документации ssl включается только при доступе покупателя в личный кабинет или оформлении заказа - все остальное работает на http
      соответственно при нажатии кнопки оформить заказ включается ssl и плывут все стили cms заказ не оформить - также плывет админка магазина - в нее можно войти - но работать нет - стили не подгружаются.
      ну и собственно говоря вопрос - ЧТО Я ДЕЛАЮ НЕ ТАК?
  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.