DmitryKaras

[Решено {IIS и .htaccess}] Проблема после переноса на хостинг

Рекомендуемые сообщения

DmitryKaras    0

Добрый день. Столкнулся со следующей проблемой.

На локалке все работало ок. А теперь при переходи по пунктам меню, а также при переходе по категориями (например http://finic.by/zaryadnyie-ustroystva/)

Not Found

The requested document was not found on this server.

 

Однако если очистить пункт при заполнение seo url в админке, то

http://finic.by/index.php?route=product/category&path=68 вот так получается

 

у меня мысль на .htaccess.  сайт находится на виндовом хостинге путь (D:\vhosts\finic.by\httpdocs)

 

Подскажите. Очень буду благодарен

 Тех поддержка хостинга говорит переходить лучше на линуксовый хостинг

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Helloween    6

.htaccess содержит такую строчку:

RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

если она у вас закомментирована - то будет выдавать ошибку. попробуйте ее раскомментировать (убрать # решетку впереди)
 
Помимо этого, он у вас ищет по этому адресу документ, а не каталог. (The requested document was not found on this server.)
То есть, необходимы условия для правил замены:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis    1 091

скорее всего использовали ftp-клиент, который не показывает файлы, начинающиеся с точки, и не загрузили .htaccess на сервак.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Helloween    6

скорее всего использовали ftp-клиент, который не показывает файлы, начинающиеся с точки, и не загрузили .htaccess на сервак.

Или убрать расширение .txt забыли...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
DmitryKaras    0

 

.htaccess содержит такую строчку:

RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

если она у вас закомментирована - то будет выдавать ошибку. попробуйте ее раскомментировать (убрать # решетку впереди)

 

Помимо этого, он у вас ищет по этому адресу документ, а не каталог. (The requested document was not found on this server.)

То есть, необходимы условия для правил замены:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

проверил RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]  - не закомментирован.

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

также не закоментирован.

файл проверил точно без txt на конце. да я в приницпе ничего и не менял внутри .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Helloween    6

Скиньте листинг файла сюда.

Только оберните в тег code

4xGIpLwt.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
DmitryKaras    0

Скиньте листинг файла сюда.

Только оберните в тег code

4xGIpLwt.jpg

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis    1 091

:ugeek: не обратил внимания на

сайт находится на виндовом хостинге путь (D:\vhosts\finic.by\httpdocs)

Тех поддержка хостинга говорит переходить лучше на линуксовый хостинг

1. а там точно apache, а не IIS или что-то другое?

2. вас что-то держит на виндовом?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
DmitryKaras    0

:ugeek: не обратил внимания на

1. а там точно apache, а не IIS или что-то другое?

2. вас что-то держит на виндовом?

уточнил. хостеры ответили что iis

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis    1 091

.htaccess это для apache. на IIS он не работает.

там "своя кухня" с rewrite.

езжайте на nix`овый хостинг с apache.

Изменено пользователем afwollis

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
DmitryKaras    0

.htaccess это для apache. на IIS он не работает.

там "своя кухня" с rewrite.

езжайте на nix`овый хостинг с apache.

уже делаем запрос у хостеров

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
DmitryKaras    0

спасибо всем за помощь! низкий поклон! завтра пробуем на линуксовом хостинге

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу