Перейти к содержанию
kezya

Необходима доставка - как исправить

Рекомендуемые сообщения

Добрый день уважаемые форумчане! У меня в настройках товаров по умолчанию стоит "Необходима доставка" - "нет", а теперь мне нужно в тысячах товаров поставить необходима доставка - "да", подскажите как это сделать? или через БД или еще какой нить способ, так как теперь в оформлении заказа нужно сделать шаг "Доставки"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

UPDATE oc_product SET `shipping`=1;
где, вместо oc_ используйте свой префикс к БД.

Этот запрос поменяет необходима доставка = "да" для ВСЕХ товаров.

Изменено пользователем shoputils

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
UPDATE oc_product SET `shipping`=1;
где, вместо oc_ используйте свой префикс к БД.

Этот запрос поменяет необходима доставка = "да" для ВСЕХ товаров.

 

Спасибо, думаю тему можно закрыть!)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подскажите еще пожалуйста, после того как прописал запрос на апдейт они то стали "Необходима доставка", но! когда захожу в товар через админку и сохраняю его, у этого товара слетает "необходима доставка", так как галочка по умолчанию стоит на  "Необходима доставка" - "Нет", так и сохраняет, тоесть перед каждым пересохранением товара надо выставлять "Необходима доставка", как сделать чтобы по умолчанию захода в товар она была "Да"?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
UPDATE oc_product SET `shipping`=1;
где, вместо oc_ используйте свой префикс к БД.

Этот запрос поменяет необходима доставка = "да" для ВСЕХ товаров.

 

Тоже так делал, но после этого резко стало невозможно зайти в корзину, как исправить не знаю

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 25.08.2014 в 14:10, shoputils сказал:

 


UPDATE oc_product SET `shipping`=1;

где, вместо oc_ используйте свой префикс к БД.

Этот запрос поменяет необходима доставка = "да" для ВСЕХ товаров.

 

Актуально ли для версии 2.3.0.2.3?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
46 минут назад, MFX сказал:

 

Актуально ли для версии 2.3.0.2.3?

да

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.