Jump to content
Sign in to follow this  
ex0

VQMOD не работает только в админке

Recommended Posts

Такая вот странная проблема, везде работает, а для файлов админки — нет. Логи пустые, ошибок нет, права стоят, не работает ни локально на Денвере, ни на хосте. Гуглил много, подобных проблем не нашел. Стоит ocStore 1.5.4.1, VQMOD последний.

Share this post


Link to post
Share on other sites

Такая вот странная проблема, везде работает, а для файлов админки — нет. Логи пустые, ошибок нет, права стоят, не работает ни локально на Денвере, ни на хосте. Гуглил много, подобных проблем не нашел. Стоит ocStore 1.5.4.1, VQMOD последний.

index.php в директории /admin/ в студию.

Share this post


Link to post
Share on other sites

index.php в директории /admin/ в студию.

 

Пожалуйста.

index.php

Share this post


Link to post
Share on other sites

Пожалуйста.

 

Например, какой файл для админки не работает?

А если почистить кеш vqmod(полностью папку), и mods.cache?

Share this post


Link to post
Share on other sites

Например, какой файл для админки не работает?

А если почистить кеш vqmod(полностью папку), и mods.cache?

 

Например, вот этот мод не работает https://opencartforum.com/files/file/197-admin-jquery-striped-tables-plus-restyling/

Все чистил, ничего не помогает.

Share this post


Link to post
Share on other sites

Например, вот этот мод не работает https://opencartforum.com/files/file/197-admin-jquery-striped-tables-plus-restyling/

Все чистил, ничего не помогает.

config.php в студию, из директории /admin/ (предварительно затерев данные от базе данных)

Share this post


Link to post
Share on other sites

config.php в студию, из директории /admin/ (предварительно затерев данные от базе данных)

 

Вроде все ок.

config.php

Share this post


Link to post
Share on other sites

Возможность фтп предоставить в личку есть?

Интересно..

Share this post


Link to post
Share on other sites

Возможность фтп предоставить в личку есть?

Интересно..

 

Готово, выслал.

Share this post


Link to post
Share on other sites

Готово, выслал.

 

Неправильно пути указываете в config.php

через phpinfo() берёте правильный вариант, и вставляете в конфиг.

Собственно, это я вам и сделал :oops:

Share this post


Link to post
Share on other sites

Спасибо большое!

Share this post


Link to post
Share on other sites

Можете показать правленый config.php?

Такая же история не работает в админке.

 

Share this post


Link to post
Share on other sites

Можете показать правленый config.php?

Такая же история не работает в админке.

 

Вместо "define('DIR_APPLICATION', '../admin/');" и др. нужно прописывать полный путь: "define('DIR_APPLICATION', '/home/user1234/public_html/happycosmeticsru/admin/');". Уточните в тп хостера путь для вашей папки, так же можно посмотреть через phpinfo.

Share this post


Link to post
Share on other sites

Вместо "define('DIR_APPLICATION', '../admin/');" и др. нужно прописывать полный путь: "define('DIR_APPLICATION', '/home/user1234/public_html/happycosmeticsru/admin/');". Уточните в тп хостера путь для вашей папки, так же можно посмотреть через phpinfo.

 

Дружище!

Нет ... братан!

Спасибо огромное, пропотел 3 дня! Наконец-то появилась в админке сеопро! Спасибо еще раз!

Share this post


Link to post
Share on other sites

Дружище!

Нет ... братан!

Спасибо огромное, пропотел 3 дня! Наконец-то появилась в админке сеопро! Спасибо еще раз!

 

Спасибо SPositive за то, что разобрался в чем корень проблемы :)

Share this post


Link to post
Share on other sites

В админке перестало работать это

vqmod не хотит работать(

в конфиге пути полные прописаны

и фильтры отвалились

похоже vqmod точно перестал работать

 

заработало, не знаю что за глюк был. очистил кэш самого vqmod и из папки system/cache

Share this post


Link to post
Share on other sites

Этот способ для локалки проканает? Ни один мод для админ файлов не хочет срабатывать. В конфиге стоит

define('DIR_APPLICATION', 'Y:\home\test8.ru\www/admin/');

Share this post


Link to post
Share on other sites

Этот способ для локалки проканает? Ни один мод для админ файлов не хочет срабатывать. В конфиге стоит

define('DIR_APPLICATION', 'Y:\home\test8.ru\www/admin/');

 

Да, конечно, только замените все слэши на такой: /

Share this post


Link to post
Share on other sites

Да, конечно, только замените все слэши на такой: /

Неверно.

Если у гражданина платформа windows, то он всё верно сделал.

 

Ищите проблему в другом.

На край, загружаете файл с внутреностями phpinfo(), и проверяем коректность пути.

Share this post


Link to post
Share on other sites

Ну, не знаю. У меня именно так заработало. В phpinfo() полный путь был с такими слэшами.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.