Перейти к содержанию
mobiliti

[Решено] Warning: set_time_limit() on line 76

Рекомендуемые сообщения

Возникла проблема при экспорте, на локалке все работает, залил на хост, не работает экспорт, выдает ошибки: Warning: set_time_limit() has been disabled for security reasons in /var/www/ваш_сайт/ваш_сайт/admin/controller/tool/export.php on line 76 и много текста

Вот решение этой проблемы: заходим на хостинг ваш_сайт /admin/controller/tool открываем файл export.php находим строки:

// set appropriate memory and timeout limits
			ini_set("memory_limit","128M");
			set_time_limit( 1800 );
и удаляем их.
  • +1 4

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

написано же

Warning: set_time_limit() has been disabled for security reasons
так что это вопрос относительно настроек хостинга.

вам помогло удаление, кому-то поможет хостер, исключив эту функцию из списка запрещенных...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Дело в том, что хостинг мне тоже не помог я туда звонил, они подняли до: 600 максимум, ну это мне не помогло

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Дело в том, что хостинг мне тоже не помог я туда звонил, они подняли до: 600 максимум, ну это мне не помогло

я эту проблему решил иначе:

1.удалил строки, которые описаны выше

2.внес изменения в файл .htaccess

добавил строку, которая заменяет дефолтовые настройки хостера. Пока со стороны хостера претензий нет. :)

в файл .htaccess добавить

php_value max_execution_time 960
значение можно подобрать самому.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Наконец-то решилась проблема, и все благодаря mobiliti! У меня на хостинге TimeWeb все отлично экспортировалось, а на Мастерхосте была эта ошибка. Вообще Мастерхост по всем параметрам сильнее (по максимальным нагрузкам, на другом движке Шопос даже фильтр 1000 товаров без проблем выводил на 1 странице, выискивая из 2000). Но данное ограничение не давало работать.

Спасибо вам!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Возникла проблема при экспорте, на локалке все работает, залил на хост, не работает экспорт, выдает ошибки: Warning: set_time_limit() has been disabled for security reasons in /var/www/ваш_сайт/ваш_сайт/admin/controller/tool/export.php on line 76 и много текста

Вот решение этой проблемы: заходим на хостинг ваш_сайт /admin/controller/tool открываем файл export.php находим строки:

// set appropriate memory and timeout limits
			ini_set("memory_limit","128M");
			set_time_limit( 1800 );
и удаляем их.

 

Спасибо большое, помогло с решением моей проблемы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.