Перейти к содержанию
tirpits

[Решено] "Съезжает" главная страница

Рекомендуемые сообщения

Здравствуйте. У моего магазина "Съезжает" главная страница (товары по центру отображаются под подвалом) в IE, в остальных браузерах все хорошо, нашел здесь тему... о кодировках, мне это не помогло, или сделал не так. Подскажите плиз, что сделать нужно, где исправить и что?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Решена проблема так:

Восстановил изначальный файл в catalog/language/russian/common/footer.php все заработало корректно на всех браузерах

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вообщем, - опять двадцать пять.

Путем исключения, пришел к тому что НЕ устанавливая дополнительных модулей и НЕ чего не исправляя (с нуля)- главная страница снова и снова "разбивается" в IE, полностью переустанавливал магазин раз 4-5 и после непродолжительного времени это снова происходит. Вот незадача, причем у меня на opencart несколько магазинов и все на одном хосте (это к тому что хостинг не причем, там все работает),в других магазинах я изменения вносил... многое менял и переделывал и все на IE работает четко, а тут... чертовщина какая... ?????? остается одно, возможно фото которые я загружаю в data как то на это влияют? не тот формат может? ? ? у меня вообще больше вариантов нет...

Вывод:

Из трех магазинов на одном хосте, Два, где были множественные исправления и доп. модули работают во всех браузерах.

А один... ну вы же прочитали...(((

Прошу помощи.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я выяснил: это происходит после того как я импортирую базу данных, но не понятно пока в связи с чем эта напасть...

post-6166-0-36927700-1301751132_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

где то незакрытый тег у вас

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

где то незакрытый тег у вас

Не закрытый тег в импортируемой базе данных?

Этот магазин установлен "с нуля" без исправлений и доп. модулей, получается косяк идет с сайта где взята база данных... это лечится?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

все лечится, даже то что вы надеетесь найти ответ по, во-первых, обрезанной, во-вторых, картинке)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема решена:

Я переносил базу данных на хост для нового домена и в только что установленный магазин добавлял еще и товар (импорт) сразу после этого главная страница "слетала" (модули здесь не причем).

Решение: Выбираем что-то одно или добавляем базу данных или делаем Импорт (вместе они работают но некорректно в IE).

Всем спасибо за участие.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Опять двадцать пять

Снова тема открыта! Не лечится, проработал сайт сутки и опять не только главная страница слетела уже по ходу все поехало, 5 дней и ночей вычислял по шагам проверяя после каждого добавленного модуля... не получилось, может есть у кого добрый совет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вот скриншоты...

post-6166-0-67706100-1302007475_thumb.png

post-6166-0-06298500-1302007485_thumb.png

post-6166-0-00772300-1302007493_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуй сменить доктайп, например:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Проблема на всех языках? Если только на одном то проверь кодировку языкавых файлов. Всюду должно быть UTF-8 без BOOM

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вот теперь всё! разобрался!

Вот оно что: при установке модулей какой-то из них вносит изменения в файлы /public_html/catalog/language/russian/module, я обновил "родные" файлы и главная страница стала отображаться в IE корректно! тоже самое нужно сделать в /public_html/catalog/language/russian/product и странички с товарами стали тоже идеальны в IE, при этом все установленные дополнительно модули работают без проблем! Итог работы 5 дней, 5 ночей)))

Всем спасибо!!!

post-6166-0-98123300-1302028521_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.