Jump to content

Recommended Posts

Здравствуйте! Помогите, пожалуйста, решить проблему со слайдером. Он у меня почему-то перестал грузить картинки. Баннеры есть, все настроено, но они не показываются, а вместо картинок крутится загрузка. Что с этим можно сделать?

 

 

post-669247-0-31156000-1371645572_thumb.png

Share this post


Link to post
Share on other sites

Адрес пациента!

Share this post


Link to post
Share on other sites

Возможно проблема именно в картинках(формат,названия на кирилице итд)

Share this post


Link to post
Share on other sites

Возможно проблема именно в картинках(формат,названия на кирилице итд)

да нет, сначала не грузились картинки, стоящие по умолчанию, а потом и загруженные мной... названия на латинице... я уже голову сломала и весь интернет перерыла, но не могу найти ответ - похоже, такой проблемы ни у кого не было (((

Share this post


Link to post
Share on other sites

Как вариант,почистить системный кеш, кеш картинок,ну и задать этот вопрос хостингу.Раз всё работало до этого.

Share this post


Link to post
Share on other sites

Как вариант,почистить системный кеш, кеш картинок,ну и задать этот вопрос хостингу.Раз всё работало до этого.

Кэш почистила, а кэш картинок где чистить?... Может это где-то в файлах не "подхватывается" картинка? только я не знаю, какие файлы смотреть...

Share this post


Link to post
Share on other sites

Тогда так.....Картинки изначально были? 

Share this post


Link to post
Share on other sites

Тогда так.....Картинки изначально были? 

да, были в шаблоне

Share this post


Link to post
Share on other sites

У вас библиотека jquery  подключена несколько раз. При беглом просмотре вот это

<script type="text/javascript" src="jquery-1.10.1.js"></script>

 

лишнее.

Share this post


Link to post
Share on other sites

У вас библиотека jquery  подключена несколько раз. При беглом просмотре вот это

<script type="text/javascript" src="jquery-1.10.1.js"></script>

 

лишнее.

То есть это надо выключить? это же последняя версия, насколько я понимаю?

Share this post


Link to post
Share on other sites

Хотите последнюю версию оставить, тогда исключите это (только версия 1.7.1 - 91кБ, а 1.10.1 - 270кБ)



<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

Share this post


Link to post
Share on other sites

Хотите последнюю версию оставить, тогда исключите это

<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

чтоб я знала, где и как это сделать (((((, а вообще, какую версию лучше использовать? я ничего в этом не понимаю, к сожалению

Share this post


Link to post
Share on other sites

 

Хотите последнюю версию оставить, тогда исключите это

<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

чтоб я знала, где и как это сделать (((((, а вообще, какую версию лучше использовать? я ничего в этом не понимаю, к сожалению

Кажется, мне что-то удалось - в файле 

/catalog/view/theme/universal-purple/template/common/header.tpl есть строчка
<?php
 
$showbanners='0';  //Если указать "1", то будут отображаться баннеры на главной 
                    //Если указать "0", то не будут отображаться баннеры на главной 
 
?>
 
Поставила 1 вместо 0, и появились баннеры... кривые и косые, но появились
 
 

Share this post


Link to post
Share on other sites

Вообще обычно скрипты прописываются в файле catalog\view\theme\ваша_тема\template\common\header.tpl

В нем и удалите / закомментируйте соответствующую строку.

Share this post


Link to post
Share on other sites

Вообще обычно скрипты прописываются в файле catalog\view\theme\ваша_тема\template\common\header.tpl

В нем и удалите / закомментируйте соответствующую строку.

Спасибо! Я так и сделала... Сейчас вроде бы работает - буду дальше копаться

Share this post


Link to post
Share on other sites

А теперь новая напасть - кнопки смены картинок съехали вправо и вниз

post-669247-0-40617100-1371653696_thumb.png

Share this post


Link to post
Share on other sites

Попробуйте почитать эту тему

Спасибо! К сожалению, не помогло

Share this post


Link to post
Share on other sites
в slideshow.css
строка 105 

удалить зачеркнутое
 
.slideshow .nivo-controlNav {
position: absolute;  <------ параметр который Вам все портит ("ломает" позиционирование кнопки в  
                                          диве со слайдером и отправляет в "свободное плавание" по странице)
right: 10px;
bottom: 5px;
text-align: center;  <--- абсолютно бесполезно
height: 22px;
z-index: 99;
}
 
ну и что бы справа осталось: 
.slideshow .nivo-controlNav {
        float:right;
	right: 10px;
	bottom: 5px;
	height: 22px;
	z-index: 99;
}

 

 

Share this post


Link to post
Share on other sites
в slideshow.css
строка 105 

удалить зачеркнутое

 
.slideshow .nivo-controlNav {
position: absolute;  <------ параметр который Вам все портит ("ломает" позиционирование кнопки в  
                                          диве со слайдером и отправляет в "свободное плавание" по странице)
right: 10px;
bottom: 5px;
text-align: center;  <--- абсолютно бесполезно
height: 22px;
z-index: 99;
}
 
ну и что бы справа осталось: 

.slideshow .nivo-controlNav {
        float:right;
	right: 10px;
	bottom: 5px;
	height: 22px;
	z-index: 99;
}

 

 

Спасибо! 

Я уже обрадовалась, что помогло... но при добавлении в слайдшоу больше одного баннера вылезают еще кнопки и вообще каша какая-то получается...

Это решение хорошо, если только один баннер... В любом случае - Спасибо!

Share this post


Link to post
Share on other sites

1. я не в курсе какую Вы там "кашу" варите но вот так: 

position: /*absolute*/;

ни кто не комментирует, уж поверьте мне

может все ж вот так? 

/*position: absolute;*/
 

2. непонятно зачем справа еще слайдеры? если можно туда поместить модуль банер? 

Share this post


Link to post
Share on other sites

1. я не в курсе какую Вы там "кашу" варите но вот так: 

position: /*absolute*/;

ни кто не комментирует, уж поверьте мне

может все ж вот так? 

/*position: absolute;*/
 

2. непонятно зачем справа еще слайдеры? если можно туда поместить модуль банер? 

Исправила. Спасибо, что заметили - это я, видимо, уже заработалась )))....

Share this post


Link to post
Share on other sites

Такая же проблема как и в первом посту. Идет загрузка изображение на слайдере http://whiskyburo.com

Все ископал. Вроде все скрипты правильно отображены. Где еще копать? Картинки с латинским названием.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.