Yuliko

Слайдер не грузится

Рекомендуемые сообщения

Yuliko    3

Здравствуйте! Помогите, пожалуйста, решить проблему со слайдером. Он у меня почему-то перестал грузить картинки. Баннеры есть, все настроено, но они не показываются, а вместо картинок крутится загрузка. Что с этим можно сделать?

 

 

post-669247-0-31156000-1371645572_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Strelez    99

Адрес пациента!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 012

Возможно проблема именно в картинках(формат,названия на кирилице итд)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Возможно проблема именно в картинках(формат,названия на кирилице итд)

да нет, сначала не грузились картинки, стоящие по умолчанию, а потом и загруженные мной... названия на латинице... я уже голову сломала и весь интернет перерыла, но не могу найти ответ - похоже, такой проблемы ни у кого не было (((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 012

Как вариант,почистить системный кеш, кеш картинок,ну и задать этот вопрос хостингу.Раз всё работало до этого.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Как вариант,почистить системный кеш, кеш картинок,ну и задать этот вопрос хостингу.Раз всё работало до этого.

Кэш почистила, а кэш картинок где чистить?... Может это где-то в файлах не "подхватывается" картинка? только я не знаю, какие файлы смотреть...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 012

Тогда так.....Картинки изначально были? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Тогда так.....Картинки изначально были? 

да, были в шаблоне

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Strelez    99

У вас библиотека jquery  подключена несколько раз. При беглом просмотре вот это

<script type="text/javascript" src="jquery-1.10.1.js"></script>

 

лишнее.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

У вас библиотека jquery  подключена несколько раз. При беглом просмотре вот это

<script type="text/javascript" src="jquery-1.10.1.js"></script>

 

лишнее.

То есть это надо выключить? это же последняя версия, насколько я понимаю?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Strelez    99

Хотите последнюю версию оставить, тогда исключите это (только версия 1.7.1 - 91кБ, а 1.10.1 - 270кБ)



<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Хотите последнюю версию оставить, тогда исключите это

<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

чтоб я знала, где и как это сделать (((((, а вообще, какую версию лучше использовать? я ничего в этом не понимаю, к сожалению

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

 

Хотите последнюю версию оставить, тогда исключите это

<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

чтоб я знала, где и как это сделать (((((, а вообще, какую версию лучше использовать? я ничего в этом не понимаю, к сожалению

Кажется, мне что-то удалось - в файле 

/catalog/view/theme/universal-purple/template/common/header.tpl есть строчка
<?php
 
$showbanners='0';  //Если указать "1", то будут отображаться баннеры на главной 
                    //Если указать "0", то не будут отображаться баннеры на главной 
 
?>
 
Поставила 1 вместо 0, и появились баннеры... кривые и косые, но появились
 
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Strelez    99

Вообще обычно скрипты прописываются в файле catalog\view\theme\ваша_тема\template\common\header.tpl

В нем и удалите / закомментируйте соответствующую строку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Вообще обычно скрипты прописываются в файле catalog\view\theme\ваша_тема\template\common\header.tpl

В нем и удалите / закомментируйте соответствующую строку.

Спасибо! Я так и сделала... Сейчас вроде бы работает - буду дальше копаться

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

А теперь новая напасть - кнопки смены картинок съехали вправо и вниз

post-669247-0-40617100-1371653696_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

Попробуйте почитать эту тему

Спасибо! К сожалению, не помогло

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Pascha    645
в slideshow.css
строка 105 

удалить зачеркнутое
 
.slideshow .nivo-controlNav {
position: absolute;  <------ параметр который Вам все портит ("ломает" позиционирование кнопки в  
                                          диве со слайдером и отправляет в "свободное плавание" по странице)
right: 10px;
bottom: 5px;
text-align: center;  <--- абсолютно бесполезно
height: 22px;
z-index: 99;
}
 
ну и что бы справа осталось: 
.slideshow .nivo-controlNav {
        float:right;
	right: 10px;
	bottom: 5px;
	height: 22px;
	z-index: 99;
}

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3
в slideshow.css
строка 105 

удалить зачеркнутое

 
.slideshow .nivo-controlNav {
position: absolute;  <------ параметр который Вам все портит ("ломает" позиционирование кнопки в  
                                          диве со слайдером и отправляет в "свободное плавание" по странице)
right: 10px;
bottom: 5px;
text-align: center;  <--- абсолютно бесполезно
height: 22px;
z-index: 99;
}
 
ну и что бы справа осталось: 

.slideshow .nivo-controlNav {
        float:right;
	right: 10px;
	bottom: 5px;
	height: 22px;
	z-index: 99;
}

 

 

Спасибо! 

Я уже обрадовалась, что помогло... но при добавлении в слайдшоу больше одного баннера вылезают еще кнопки и вообще каша какая-то получается...

Это решение хорошо, если только один баннер... В любом случае - Спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Pascha    645

1. я не в курсе какую Вы там "кашу" варите но вот так: 

position: /*absolute*/;

ни кто не комментирует, уж поверьте мне

может все ж вот так? 

/*position: absolute;*/
 

2. непонятно зачем справа еще слайдеры? если можно туда поместить модуль банер? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yuliko    3

1. я не в курсе какую Вы там "кашу" варите но вот так: 

position: /*absolute*/;

ни кто не комментирует, уж поверьте мне

может все ж вот так? 

/*position: absolute;*/
 

2. непонятно зачем справа еще слайдеры? если можно туда поместить модуль банер? 

Исправила. Спасибо, что заметили - это я, видимо, уже заработалась )))....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
LancX    3

Такая же проблема как и в первом посту. Идет загрузка изображение на слайдере http://whiskyburo.com

Все ископал. Вроде все скрипты правильно отображены. Где еще копать? Картинки с латинским названием.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу