Jump to content
Sign in to follow this  
Leva888

Вопрос по php

Recommended Posts

Приветствую,

Вопрос прост, но я не могу ни как решить. Поставил плагин который скрывает кнопку корзины при отсутствии товара, но мне надо чтобы вместо пустого текста писАлось "нет в наличии".

 

Вот код

 

<input type="button" value="" <?php if ($product['quantity'] <= 0) { echo 'style="display:none"'; } ?>
onclick="addToCart('<?php echo $product['product_id']; ?>');" class="btn btn-cart" /></div>

Т.е. мне надо чтобы вместо display:none был текст "нет в наличии".

 

А еще лучше было бы если бы картинку выводил.

 

Буду признателен за помощь.

Share this post


Link to post
Share on other sites

для этого есть готовый модуль. Вы сделали почти правильно, но скрывать кнопку не нужно. блок с кнопкой помещается в условие, если товаров 1 или больше - то срабатывает стандартная кнопка. Если товаров 0 или меньше - условие - кнопка нет в наличии.

Share this post


Link to post
Share on other sites

я все эти модули уже пробовал применить, оттуда как раз и вытащил это условие. Они все работают только на дефолтных темах, а переписывать весь модуль смысла не вижу, эта функция уже работает как надо.

Поэтому кусок достал и хотел просто вывести текстом или картинкой, а не display:none.

 

Есть вообще возможность дописать к этой функции вывод текста или картинки, или надо все переписывать?

Share this post


Link to post
Share on other sites

я использовал этот модуль на десятках разных тем. Просто нужно ручками вводить изменения из vqmod и возможно чуток подправить.

Дайте кусок кода который у Вас отвечает за кнопку купить

Share this post


Link to post
Share on other sites

Я думал что его и указал вначале

 

Я тоже вводил изменения руками, а вот подправить не знаю как

Edited by Leva888

Share this post


Link to post
Share on other sites

Сам настроил, взял вышеуказанный Einshtein'ом модуль и руками внес все изменения. Вот только странность, когда вносил изменения перестал работать доступ к категориям товаров, причем все остальные страницы открываются без проблем.

Отключил xml модуль и опять странность, все заработало, причем с полным функционалом этого модуля.

 

Мистика чтоли?

Share this post


Link to post
Share on other sites

если вы внесли изменения, необходимые для работы какого-либо vqmod-дополнения, в движок - _само vqmod-дополнение (xml-файл)_ уже не надо использовать.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.