Jump to content
KevinJones

Notice: Undefined index: token on line 16, on line 22

Recommended Posts

Добрый день!  У меня сайт на OP Version 1.5.6.4. При входе в админ-панель получаю "Страница не найдена!"  и Notice: Undefined index: token in public_html/мой_сайт/admin/controller/error/not_found.php on line 16Notice: Undefined index: token in public_html/мой_сайт/admin/controller/error/not_found.php on line 22. Подскажите, пожалуйста, как это исправить. Проверил оба конфига, все хорошо. Читал, что такая ошибка свойственна Open Cart 3, тогда почему она возникла у меня?

Share this post


Link to post
Share on other sites
7 часов назад, KevinJones сказал:

Проверил оба конфига, все хорошо

 

наверное, не совсем

вот схожая тема и причина

 

Share this post


Link to post
Share on other sites

@AlexDW  Порывшись в интернете, чтобы зайти в админку применил следующее - залил чистые index.php (у меня установлен vqmod). В админку пустило. И там я увидел, что легло MultiSeller и "Доставка и оплата", "Добавление нового продавца" перестали работать. Вычитал, что это связано с проблемой в vqmod, что не удивительно, ведь я его удалил, чтобы попасть в админку. Что сейчас делать, не представляю...

Только что снова залил старые файлы index.php(с vqmod) - вход в админку сохранился. Вот только [MultiMerch] Digital Marketplace удален. Получается, что дело было в нем? И что делать дальше?

Edited by KevinJones

Share this post


Link to post
Share on other sites

@AlexDW Все-таки дело в vqmod, пришлось снова залить свежие index.php, иначе в админку не пускал. Не работает "Доставка и оплата", "Добавить ваш магазин", ссылки "Возврат денежных средств", "Фотографии" - в случае ссылок вообще ведет на wamp и описание серверной конфигурации.

Share this post


Link to post
Share on other sites

Переустановил MultiSeller, уже не ругается. Осталась проблема с ссылками, ведущими в никуда. Например, в header.tpl <a href="/dostavka_i_oplata"  ведет  на The requested URL /dostavka_i_oplata was not found on this server. Личный кабинет ведет на страницу описания конфигурации и , что странно, в header.tpl вообще нет упоминания о личном кабинете. Cайт сейчас на локальном сервере, на хостинге вроде все работает. Кроме входа в админку.

Share this post


Link to post
Share on other sites

По итогу, ничего не ругается, админка есть, но ничего не работает, все ссылки(кроме отзывов) ведут к странице конфигурации. Что случилось? Как это исправить?

Edited by KevinJones

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.