Jump to content

Recommended Posts

Работал сайт днем, все хорошо. Вечером уже выдает ошибку HTTP ERROR 500

Админка работает, сам сайт нет.

Не подскажете, может где что почистить надо? Бекапы есть, но хочется понять суть проблемы. 

Share this post


Link to post
Share on other sites
Только что, Daw2666 сказал:

Работал сайт днем, все хорошо. Вечером уже выдает ошибку HTTP ERROR 500

Админка работает, сам сайт нет.

Не подскажете, может где что почистить надо? Бекапы есть, но хочется понять суть проблемы. 

Посмотрите логи сервера. Там все будет написано.

Можно ещё включить отображение ошибок, тоже поможет

 

А так только гадать.

Возможно место закончилось и кэш не создаётся.

Может модуль поставили какой-то

 

и т.д.

 

 

Share this post


Link to post
Share on other sites
Только что, Fedka сказал:

Посмотрите логи сервера. Там все будет написано.

Можно ещё включить отображение ошибок, тоже поможет

 

А так только гадать.

Возможно место закончилось и кэш не создаётся.

Может модуль поставили какой-то

 

и т.д.

 

 

Ошибки только такие, но они были давно из-за модуля, на работу не влияло. Модули поставили, но после них все работало

Undefined index: position in /var/www/admin/www/.../system/storage/modification/catalog/controller/extension/module/html.php on line 8Notice: Undefined index: position in /var/www/admin/www/.../system/storage/modification/catalog/controller/extension/module/html.php on line 11

Edited by Daw2666

Share this post


Link to post
Share on other sites

Может кто за денюжку посмотрит :)

Share this post


Link to post
Share on other sites
8 минут назад, Daw2666 сказал:

Модули поставили, но после них все работало

Обновление шаблона не делали?

Может адоптация какого-то модуля слетела.

 

Не открывается только главная? Страница категории, товара открываются?

Share this post


Link to post
Share on other sites
Только что, Fedka сказал:

Обновление шаблона не делали?

Может адоптация какого-то модуля слетела.

 

Не открывается только главная? Страница категории, товара открываются?

И правда, не открывается только главная. В логах сервера есть такое:

[23/May/2019:22:21:14 +0300] "GET / HTTP/1.0" 500 488 "http://.../admin/index.php?route=common/dashboard&token=ТУТ ТОКЕН" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36"

Шаблон не обновляли. Утром установили модуль, после него все работало. Удалили модуль - не работает.

Share this post


Link to post
Share on other sites
1 минуту назад, Daw2666 сказал:

В логах сервера есть такое:

это access_log ищите рядом errors_log

Share this post


Link to post
Share on other sites
5 минут назад, Daw2666 сказал:

И правда, не открывается только главная. В логах сервера есть такое:

[23/May/2019:22:21:14 +0300] "GET / HTTP/1.0" 500 488 "http://.../admin/index.php?route=common/dashboard&token=ТУТ ТОКЕН" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36"

Шаблон не обновляли. Утром установили модуль, после него все работало. Удалили модуль - не работает.

Можете попробовать по очередности отключать вывод модулей на главной. Если дело в каком-то модуле, тогда должна открываться главная.

Share this post


Link to post
Share on other sites

В общем, всем спасибо. Попробуем бекап поднять, повторить установку модулей и внимательно отследить на каком этапе рушится. Конфликтует с очень древним модулем, который и вызывал ошибку, но сайт работал, зато после установки нового модуля произошел конфликт и чудо перестало происходить.

Share this post


Link to post
Share on other sites
3 минуты назад, Daw2666 сказал:

В общем, всем спасибо. Попробуем бекап поднять, повторить установку модулей и внимательно отследить на каком этапе рушится. Конфликтует с очень древним модулем, который и вызывал ошибку, но сайт работал, зато после установки нового модуля произошел конфликт и чудо перестало происходить.

А не проще устранить ошибку, если Вы уже знаете какой модуль конфликтует?

Share this post


Link to post
Share on other sites
Только что, Fedka сказал:

А не проще устранить ошибку, если Вы уже знаете какой модуль конфликтует?

 

Если автор модуля поможет :) 

Share this post


Link to post
Share on other sites
10 часов назад, Daw2666 сказал:

 

Если автор модуля поможет :) 

Думаю поможет

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.