ProfiSale

Как перенести базу данных?

Рекомендуемые сообщения

ProfiSale    17

Версия 1.5.1 переношу на 1.5.4

Если просто импортировать базу в phpAdmin, то появляется куча ошибок. Я так понимаю ошибки из-за того, что на 1.5.1 установлены модули, а 1.5.4 чистая. Вот и ругается скрипт, что в БД модуль прописан, а на деле его нет.

Как тогда быть? Удалить все модули на 1.5.1 и только после этого переносить базу? Или можно как-то выделить отдельно товары и категории?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ProfiSale    17

Никто не обновлял магазин?

Сейчас получается так:

profisale.16mb.com

Прежде чем экспортировать базу с версии 1.5.1 нужно снести все сторонние модули и т.п.?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ProfiSale    17

Неужели никто OC не обновлял?

Версию БД 1.5.1 с 1.5.4 совместить то возможно?

А то уже и частями заливал, но в 1.5.4 теги в другое место вынесены, как их из 1.5.1 перенести?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Zeppelin    82

Помощь не идет по многим причинам :)

1 не указано 1.5.1 оригинальный OpenCart или местный ocStore

2 умолчал о том, что переносишь на OpenShop, а это самостоятельная модификация и у нее своя поддержка. Здесь этим движком не сильно интересуются.

теперь по делу :)

1 Автор OpenShop сам пишет модули для vqmod. Поэтому:

- В директории vqmod/xml/ оставляешь только vqmod_opencart.xml все остальные файлы временно перемещаешь в другое место. В директории должен остаться только vqmod_opencart.xml

- Из директории vqmod/vqcache/ удаляешь все файлы.

- Проверяешь ошибки

часть ошибок уйдет. Ну, а дальше надо причесать базы и все будет нормально. Хотя это неторопливая муторная работа :) но вполне реально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ProfiSale    17

1. Версия OS 1.5.1.3

2. Vqmod сейчас отключен совсем

3. А изначально переносил на сборку MaxyStore, т.к. выход OS 1.5.4 задерживается. Но перенос не получился, да и SEO там работает только для категорий.

В принципе, перенос почти удался, НО - я так понял у 1.5.4 в БД нет таблицы "теги" и что делать с тегами из БД 1.5.1.3 я так и не понял.

Надеюсь, после выхода OS 1.5.4 будет какая-нибудь инструкция о переносе базы с OS 1.5.1.3)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу