Перейти к содержанию
strong12

https не могу зайти в админку опенкарт

Рекомендуемые сообщения

https не могу зайти в админку опенкарт

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Неужели нельзя написать так, чтобы стало всем понятно? :shock:

 

Есть какая-то связь с https? Проблемы со входом возникли после перехода на https? Какая ошибка?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго всем дня! Да! Связь есть )))) при переходе на https сайт работал нормально а админка отваливалась!

Как выяснилось в одном из " конфигов " почему то было вот так define  ('HTTP _SERVER', 'https://clima24.ru/admin/');
define('HTTP_CATALOG', 'https://clima24.ru/'); не были дописанны буквы S......

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

То есть конфиги поправлены и проблема в итоге решилась?

У вас, кстати, сайт доступен как с www, так и без. Это плохо. Сделайте редирект.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо за подсказку! Это вроде нужно в htaccess что то дописать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, strong12 сказал:

Спасибо за подсказку! Это вроде нужно в htaccess что то дописать?

Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.clima24\.ru$ [NC]
RewriteRule ^(.*)$ https://clima24.ru/$1 [R=301,L]

Вот так вроде?

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Первые две строки там уже есть.

Нужно добавить:

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо за ответ! Но я не совсем понял....

Именно в таком виде добавить? Или в них нужно доменное имя прописывать? Если да то куда именно?

 Сейчас у меня вот так :

Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.clima24\.ru$ [NC]
RewriteRule ^(.*)$ https://clima24.ru/$1 [R=301,L]

+ То что вы написали

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Именно в таком. Вместо.

Но можете и свой вариант оставить.

 

Надеюсь, это второй раз не вставляли?:

Options +FollowSymLinks
RewriteEngine On

В файле эти строки уже есть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет не встаил)))))))))))))))) Спасибо большое за дельные советы!!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.