Jump to content

Zapuzin

Пользователи
  • Content Count

    89
  • Joined

  • Last visited

Community Reputation

3 Обычный

About Zapuzin

  • Rank
    Пользователь

Информация

  • Пол
    Мужчина

Recent Profile Visitors

965 profile views
  1. Проблема решена. Ошибки больше не появляются.
  2. Проблема решена. Оказалось всё очень просто. В языковой файл фильтра добавил то, что было уже прописано в языковом файле pds.php ) С системными ошибками, связанными с "Product Display Settings" вроде тоже справляюсь. Ради эксперимента убрал код дубль (нижний), на который ругалась система (изменил в xml файле, чтобы вставлялся один раз). Функционал на сайте в пределах модуля не изменился. Ошибок пока нет. Похоже, что повторение этого кода ниже не имеет значения. filterpro отключил. Мониторю )
  3. thentru, Ради эксперимента убрал код дубль (нижний), на который ругалась система (изменил в xml файле, чтобы вставлялся один раз). Функционал на сайте в пределах модуля не изменился. Ошибок пока нет. Похоже, что повторение этого кода ниже не имеет значения. filterpro отключил. Мониторю )
  4. thentru, Благодарю. Цикл, наверно, срабатывает, так как на сайте проблем с функционалом модуля "product-display-settings.xml" нет. Всё работает без ошибок. Странно только то, что раньше систему всё устраивало, и этих ошибок не было. А с появлением, предположительно, этих строчек в представленных файлах (vqcache): 'statuses' => $result['statuses']['category'], 'stickers' => $result['statuses']['category_stickers'], система начала ругаться, но ошибок на сайте в границах модуля не замечено. Подозреваю, что добавление в код, который отображается два раза ( это не ошибка), одной строчки исправит проблему. Осталось только правильно её прописать. Но это, насколько понял, уже мои проблемы )
  5. Я и сам в первом сообщении привёл файлы, где искал, и где пытался исправить. С обнаружением проблем нет. Вот конкретный вопрос: почему переменная "result", которая фигурирует в данных ошибках, была всегда объявлена, а с появлением нового xml файла, стала не объявленной? Строки нового модуля присутствуют в приведённых кеш файлах. Не прошу мне исправить код, а прошу только помочь найти причину )
  6. Такой уродился. Пытаюсь решать проблемы самостоятельно. Предлагаете на этом форуме оставить только ветку "Платные услуги"? Остальные не нужны, чтобы не тратить и своё и чужое время? Это всё демагогия. По-прежнему рассчитываю на любую помощь форумчан, или хотя бы намека на решение этой проблемы.
  7. Благодарю за предложение. Платно исправить эту проблему могут многие. И это крайний случай ) Пока любопытство сильнее платных услуг, а там будем посмотреть ) Рано, или поздно я и с этой проблемой справлюсь - с помощью форумчан, или с помощью великих и могучих поисковиков, или с помощью платной услуги )
  8. Эти ошибки начали появляться только после того, как добавился файл "product_statuses.xml" свежеустановленного модуля. До этого никаких ошибок, в том числе и этих, связанных с "product-display-settings.xml", не было! Вот файлы, которые по ошибке спрятаны в пункте 1. ) 2. vq2-catalog_controller_product_manufacturer.php 3. vq2-catalog_controller_product_category.php Интересно, что до установки нового модуля не было проблем у системы с объявлением переменной "result". А теперь вдруг появилась )
  9. Сами ошибки уловимы, согласен, и вижу их в файлах vqcache, но как исправить, не знаю. Пробовал методом тыка, но безрезультатно ) Знал бы как исправить, то в песочнице не просил бы помощи ) Интересно то, что они появляются не сразу, а через некоторое время. Кстати, файлы vqcache по ошибке вложил в пункт 1. Т.е. файл в файле ) После попытки редактирования сообщения получаю ответ:
  10. Здравствуйте. ocStore-1.5.5.1.2. Шаблон OC Default 2.0. Установлено много модулей, в частности и Product Display Settings vqmod. Все они адаптированы, и работают отлично. Ошибок как в системных логах, так и в vqmod не было. Ошибки начали возникать, связанные с "product-display-settings.xml", когда появился файл "product_statuses.xml" нового модуля "Статусы Товара PRO Speed, автостатусы, стикеры, текстовые статусы". Во время экспериментальных правок "product-display-settings.xml", все ошибки отлавливались, и исправлялись. Кеш после каждой правки чистился весь (системный, vqmod). Так же установлен и "filterpro_v2.4.4(seo)", который после адаптации нормально работает с "Product Display Settings" , но с одной проблемкой, которую пытаюсь решить в "[Поддержка] filter Pro". Вот эти неуловимые ошибки ) Вот файлы, которые смотрел для устранения этих ошибок: 1. Весь "product-display-settings.xml" 4. catalog/controller/product/manufacturer.php 5. catalog/controller/product/category.php Что означают эти ошибки знаю, но не знаю, как поправить. Буду благодарен любой помощи.
  11. Странно. Появились ошибки, хотя на сайте модуль Product Display Settings отображает всё, что нужно правильно, только фильтр про не хочет значение "Наличие" товаров, которые есть в наличии, переводить ) Ошибки появились через некоторое время. Во время экспериментов с проблемным модулем кеш чистился весь, и они не появлялись ) Весь "product-display-settings.xml" vq2-catalog_controller_product_manufacturer.php vq2-catalog_controller_product_category.php Что заметил. Системные ошибки, связанные с "Product Display Settings", периодически начали появляться после того, как добавился файл "product_statuses.xml" нового модуля "Статусы Товара PRO Speed, автостатусы, стикеры, текстовые статусы". Видно им тесно вдвоём )
  12. Забыл написать, что ошибок в логах нет, как системных, так и vqmod.
  13. filterpro_v2.4.4(seo) (29.02.2016, #433262) ocStore-1.5.5.1.2 Установлен Product Display Settings vqmod В целом этот модуль с фильтром подружил, осталась только одна проблемка. Вот её никак не могу самостоятельно побороть ) Если товара нет в наличии, то "Наличие" отображается правильно, на том языке, который выбран на сайте. Если товар есть в наличии, то "Наличие" отображается неправильно - "pds_instock". Вот скрины для наглядности: Наличие без фильтра: Наличие с фильтром: "catalog/controller/product/category.php" из файла "product-display-settings.xml": "catalog/controller/module/filterpro.php" из файла "product-display-settings.xml": Вот языковой файл "catalog/language/russian/product/pds.php": " vq2-catalog_controller_module_filterpro.php" Может кто знает, как справиться с проблемой? Буду благодарен любой помощи.
    Сэкономил кучу времени и нервов. Планировал сам перевести сайт на https, но подводные камни слегка пугали. Купил услугу у профессионала. До сих пор не могу понять, как так быстро можно было справиться с работой ) Поддержка на высшем уровне. После никаких багов не замечено.Сайт работал так как и прежде. Единственное, что поправил - яндекс карту, которая перестала показываться в контактах. В файле yandexmapsvqmodcontactV2.xml ссылку с http изменил на https, и карта снова стала отображаться. Рекомендую!
×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.