Перейти к содержанию
Natulkin

Помогите!! После установки MagicZoom не работает главная

Рекомендуемые сообщения

Здравствуйте! Opencart 2.3.0.2.3

Установила модуль MagicZoom триал-версию без лицензии, скачала с оф сайта. Установила по инструкции. После установки главная страница магазина не грузится, пишет - ERR_CONTENT_DECODING_FAILED, не удается установить соединение с сайтом.  

Сам модуль работает нормально, категории, товары как надо отражаются. Только с главной проблема. 

 

В журнале ошибок:

PHP Notice:  Undefined variable: toolAbr in /home/sumkivmo/public_html/admin/view/template/extension/module/magiczoom_oc2.tpl on line 82
PHP Notice:  Undefined variable: toolAbr in /home/sumkivmo/public_html/admin/view/template/extension/module/magiczoom_oc2.tpl on line 105

 

Кусок кода со строками 82, 105:

Спойлер

<div class="tab-pane  active" id="tab-general">
  
        <div class="panel panel-default">
        <div class="panel-heading">
            <h3 class="panel-title"><i class="fa fa-pencil"></i>Module status</h3>
        </div>
        
        <div class="panel-body <?php echo $toolAbr; ?>params">
        
            <div class="form-group">
            <label class="col-sm-2 control-label" for="magiczoomsettingStatus">Enable/Disable module</label>
            <div class="col-sm-10">
              <select name="magiczoom_status" class="form-control">
                <option value="1" <?php echo (($magiczoom_status) ? 'selected' : ''); ?> ><?php echo $text_enabled; ?></option>
                <option value="0" <?php echo ((!$magiczoom_status) ? 'selected' : ''); ?> ><?php echo $text_disabled; ?></option>
              </select>
              <input type="hidden" name="magiczoom_status_was" value="<?php echo $magiczoom_status; ?>">
            </div>
            </div>
            
        </div>
        </div>
        
        <?php echo $groupsHTML['general']; ?>
        
        <div class="panel panel-default">
            <div class="panel-heading">
                <h3 class="panel-title"><i class="fa fa-pencil"></i>Other</h3>
            </div>
            
            <div class="panel-body <?php echo $toolAbr; ?>params">
                <div class="form-group">
                <label class="col-sm-2 control-label" for="magiczoomsettingChache-path">Path to cache folder</label>
                <div class="col-sm-10">
                        <input class="form-control" type="text" size="60" value="<?php echo $path_to_cache; ?>" disabled="disabled" />
                        <p class="help-block">Relative for site base path</p>
                </div>
                </div>

 

Что можно предпринять для устранения ошибки? Очень уж понравился модуль.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

для переменной toolAbr в контроллере нет строчки, может что то с модификатором не установили, не обновили? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
10 минут назад, theRGD сказал:

для переменной toolAbr в контроллере нет строчки, может что то с модификатором не установили, не обновили? 

В инструкции есть пункт - 

Если вы используете OpenCart 2.x, перейдите в [Панель администратора> Модификации] и нажмите кнопку «Обновить» .

Но я не нашла, где это можно сделать. Там есть только - дополнения, менеджер дополнений. Но там ничего нельзя обновлять. Может подскажете? 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Extensions / Modifications / кнопка обновить со значком (fa fa-refresh)

(расширения / модификаторы)

Изменено пользователем theRGD

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
14 минут назад, theRGD сказал:

Extensions / Modifications / кнопка обновить со значком (fa fa-refresh)

Обновление не помогло. Там и нет ничего, относящееся к этому модулю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
16 минут назад, Natulkin сказал:

Обновление не помогло. Там и нет ничего, относящееся к этому модулю.

я к сожалению не столкнулся с такой проблемой при установке, закомментируйте эти строчки в tpl

 

mbx.PNG

эти устанавливать не надо!

Изменено пользователем theRGD

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, theRGD сказал:

я к сожалению не столкнулся с такой проблемой при установке, закомментируйте эти строчки в tpl

 

mbx.PNG

эти устанавливать не надо!

 

Простите, я новичок в этом деле(( Вписать эти строчки в файл? В каком виде и куда?

Хорошо, что не столкнулись. Целый день пытаюсь решить эту проблему...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.