Перейти к содержанию

Рекомендуемые сообщения

Здравствуйте.

Предыстория такова: на OpenCart 2.1.0.2 (rs.1) перестал работать модуль. Причины неизвестны - работал-работал, и пропал. Полез в админку, попытался зайти в редактирование фильтра - выпала ошибка

Fatal error: Call to a member function activate() on a non-object in <file> on line 2343

Потом обратился к разработчику сайта с просьбой скинуть файлы фильтра, и данные для активации.

Пошёл сносить модуль ... Сначала отключил его, потом очистил+обновил модификаторы, и пошёл сносить все файлы в SSH. Процесс удаления был не безболезненным (не был установлен DOM на сервере), но эта проблема решилась быстро.

На данный момент было перепробовано несколько вариантов до-пере-установки фильтров с разными инструкциями и видео из гугла. После установок-удалений модуля, модификаторы чистил/обновлял.
Из наиболее важных ссылок, которые я посещал - форум и видео (у меня OCMod).

Результат везде один и тот же - ошибки не вываливаются, но фильтр на сайте не отображается.

В самой админке (в разделе модулей) написано следующее: "После установки и настройки модуля вы можете добавить его на макет в разделе Дизайн-Макеты!".

Полез в указанное место, обнаружил там Mega Filter PRO как самостоятельный макет. Добавление в него "Модуль" Категории ничего не дало.

В списке модулей в макетах, самого фильтра я не обнаружил.

Что вы можете подсказать-предложить ?

Изменено пользователем MNAberkut

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
19 минут назад, MNAberkut сказал:

Потом обратился к разработчику сайта с просьбой скинуть файлы фильтра, и данные для активации.

Пошёл сносить модуль ...

Взял файлы и ключи от лицензионного фильтра ,при чём самого дорого на данный и момент и стал сносить?

Так может сносить приходится из за того,что фильтр не имеет той самой лицензии?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 минут назад, Tom сказал:

Так может сносить приходится из за того,что фильтр не имеет той самой лицензии?

Ну как бэ активация фильтра проходит безболезненно ... После активации спокойно открывается редактирование фильтра ... Или я чего то не знаю, что не исключено и скорее всего так и есть.

Изменено пользователем MNAberkut

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
6 минут назад, Tom сказал:

и стал сносить?

На данный момент я имею все бкапы, в том числе и с тем фильтром, который выкидывает non-object. К слову - я отлаживал файл где ошибка - там в функцию действительно ничего не приходит. Аргументы - $licence, $email и $version. Первые два пустые, хотя я их вводил ...

Кстати. это довольно таки годная идея - вставить данные активации прямо в код ... Пойду тестить =)

Изменено пользователем MNAberkut

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как узнать путь установленного модуля, для указания его в макетах ?

 

UPD: путь я нашёл, добавил - и всё равно не отображается ... Хотя ошибок уже нигде нет.

Изменено пользователем MNAberkut

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Писать автору о данной проблеме,с указанием номера заказа.

Закрыто.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.