Перейти к содержанию
ModeGam

Проблема с отображение товара после импорта через модуль Export/Import Tool (V3.10) for Ocstore 2.x

Рекомендуемые сообщения

Добрый день!

Кто может подсказать как исправить проблему с отображением товара после импорта через модуль Export/Import Tool (V3.10) for Ocstore 2.x

Товар импортируется в базу нормально. В админке отображается нормально со всеми импортированными полями. Но проблема заключается в том, что даже если поле status =1 (отображать на сайте) позиция не отображается. Чтобы позиция отобразилась нужно зайти в карточку и просто нажать кнопку сохранить, тогда позиция начинает отображаться на сайте. Кто может помочь решить данную проблему?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Чистка кеша не помогает? Попробуйте обновить модуль, уже 3,16 вышла.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кэш чистил не помогает. На модуль Export/Import Tool (V3.10) нареканий нет. До этого пользовался второй версией проблема была аналогичная, только товара было не много мог включить его ручками.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 минуты назад, ModeGam сказал:

На модуль Export/Import Tool (V3.10) нареканий нет.

 

15 минут назад, ModeGam сказал:

Но проблема заключается в том

 

Вы бы определились, есть проблема или нет проблемы. А потом автору написали бы

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
15 минут назад, nikifalex сказал:

 

 

Вы бы определились, есть проблема или нет проблемы. А потом автору написали бы

Проблема заключается именно в отображение товара на сайте. Для примера прикладываю две строки из таблицы "oc_product" у обоих поле статус равно 1. Но товар с кодом 31360 отображается на сайте, а товар с кодом 44544 нет оба товара в админке видно нормально.

image.thumb.png.a419e834ff426359d7a7a6c726fb4e0b.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

отключите ЧПУ и посмотрите результат или смените SEO_PRO на стандартный модуль ЧПУ

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
12 часов назад, ModeGam сказал:

Проблема заключается именно в отображение товара на сайте. Для примера прикладываю две строки из таблицы "oc_product" у обоих поле статус равно 1. Но товар с кодом 31360 отображается на сайте, а товар с кодом 44544 нет оба товара в админке видно нормально.

 

очевидно проблема не в статусе.

Лучше обратите внимание на model и ean.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Тоже проблема после импорта но немного другая и тоже требующая пересохранения товара в админке

Все товары в админке в списке продуктов со статусом Включено, хотя в бд status =0 и в товаре стоит Отключен

После сохранения товара статус в списке меняется на Отключено.

Все перерыл не пойму что не так здесь

 

<td class="text-left"><?php echo $product['status']; ?></td>

 

'status'     => $result['status'] ? $this->language->get('text_enabled') : $this->language->get('text_disabled'),

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.