weblifesej

SEO pro ссылка на главную

Рекомендуемые сообщения

weblifesej    1

Здравствуйте, уважаемые форумчане!

Я установил вот этот SEO pro, включил и все прекрасно работает, да вот только ссылки на некоторые стандартные информационные страницы, включая главную теперь не подчиняются ЧПУ.. и выглядят примерно так /index.php?route=common/home подскажите есть ли решение ?

 

Пробовал способ решения с помощью дописывания в .htaccess этого кода:

RewriteCond %{HTTP_HOST} ^mysite.com$ [NC]
RewriteRule ^(.*)$ http://mysite.com/$1 [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\ HTTP/
RewriteRule ^index\.html$ / [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ / [R=301,L]
RewriteCond %{QUERY_STRING} ^route=common/home$
RewriteCond %{REQUEST_METHOD} !^POST$
RewriteRule ^index\.php$ http://%{HTTP_HOST}? [R=301,L]

Это только убивает все жизненные процессы, сайт и админка вообще перестают работать.

 

Буду очень признателен за вашу помощь!

Изменено пользователем weblifesej

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
buslikdrev    38

а seu url в админке настраивали?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
weblifesej    1

Да.. слушайте, подскажите еще такое, что то он слетел непонятно почему пропал в Настроки > Сервис я его удалил, а теперь заново установить не получаеться пишет мол дубль таблиц... подскажите пожалуйтса

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

удалить
модификаторы обновить
установить заново

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
weblifesej    1

Я удалил модификатор, очистил и обновил.. но теперь при установке пишет мол неможет и дубликаты делать не хочет

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

если от него кеш остался system/storage/cache/cache.seo_pro.xxx

то удаляйте

и еще раз все очистить и обновить

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
weblifesej    1

Получилось, но теперь опять же как только ставлю ЧПУ от SEO pro так сразу в ссылку на главную страницу добавляется /index.php?route=common/home

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

хитачес нужно править

а вообще чья сборка то? версия?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
weblifesej    1

Версия чего? на плагин я в начале ссылку оставил, а opencart 2.0.1.1 

 

Кстати при создании нового товара и прописывании туда SEO URL на новый товар не работает ЧПУ но через какое-то время ЧПУ там заработал в чем может быть причина??

Изменено пользователем weblifesej

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу