Перейти к содержанию
hoolz

Наигрался с product.php до неисправляемой ошибки 500

Рекомендуемые сообщения

Доброго времени суток. Сразу приношу извинения, если создал тему не в том разделе.

 

Вот решил убрать лишние поля при добавлении товара (так гораздо удобнее и нет подсознательного страха при виде 100 полей для заполнения), вроде бы всё получилось, поля убрались и всё работало. Но решил убрать обязательное поле "Модель", поковырявшись в product.php и в итоге доигрался до того, что сайт не работает ВООБЩЕ НИКАК. Игрался с htaccess - ноль результата, удалял system/storage/cache - ноль результата, удалял vqcache - ноль результата. Даже ставил product.php и product.tpl из коробки. Все равно не работает сайт. Модификаторы обновлял, кеши чистил.

 

Пример ошибок:

2017-05-08 1:09:03 - PHP Notice:  Undefined index: length_class_id in /var/www/vh179788/data/www/тутбылсайт.ru/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 14
2017-05-08 1:09:03 - PHP Notice:  Undefined index: status in /var/www/vh179788/data/www/тутбылсайт.ru/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 14
2017-05-08 1:09:03 - PHP Notice:  Undefined index: tax_class_id in /var/www/vh179788/data/www/тутбылсайт.ru/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 14
2017-05-08 1:09:03 - PHP Notice:  Undefined index: video in /var/www/vh179788/data/www/тутбылсайт.ru/vqmod/vqcache/vq2-system_storage_modification_admin_model_catalog_product.php on line 109

 

В чём может быть проблема? Что делать?

Спасибо за внимание... Буду рад любой помощи.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Теперь кажется вообще "двинулась крыша у OpenCart".

Обратите внимание на URL.

Безымянный.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если у кого и двинулась крыша,то точно не у опенкарт.Налицо  замена файлов конфиг, плюс умелые руки.Поможет бэкап с хостинга видимо.А то судя по описанию,бардак в магазине был и до всех экспериментов.К чему в двойке Vqmod при наличии встроенного Ocmod ? Зачем было лезть в файлы,если проще и безопасней было это сделать в виде модификатора ocmod ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, Tom сказал:

.К чему в двойке Vqmod при наличии встроенного Ocmod ? Зачем было лезть в файлы,если проще и безопасней было это сделать в виде модификатора ocmod ?

 

Буду откровенен - не понимаю что за двойка и чем мне помог бы модификатор ocmod. Никогда не сталкивался с Опенкартом.

 

25 минут назад, Tom сказал:

Поможет бэкап с хостинга видимо

А это очень плохо... Потому что бэкапа нет =/

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Тогда два варианта.

1.Впадать в отчаяние.

2.В разделе платных услуг просить помощи, в обмен на денежные знаки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
26 минут назад, Tom сказал:

А то судя по описанию,бардак в магазине был и до всех экспериментов.

Ну кстати нет... Если Вы про "100 полей", то они по стандарту выводятся. А так - всё гуд.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@Tom ладно, хорошо. В любом случае спасибо за внимание. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
10 минут назад, hoolz сказал:

Ну кстати нет... Если Вы про "100 полей", то они по стандарту выводятся. А так - всё гуд.

Я не это имел в виду.Но уже не важно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Решили проблему в хостинге.

 

Цитата

Работу сайта я восстановил.
Причина - ошибки в коде:
/var/www/vh179788/data/www/тутбылсайт.ru/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_common_header.php

строки 487-489 закомментированы.

 

Теперь сайт вроде как работает, но главная страница всё ещё нет.

Постоянный редирект на /install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/index.php. Как можно решить проблему? Насколько я понял дело в config.php, но его я не трогал... И сейчас глянул - вроде всё норм.

 

 

config-admin.php

config.php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Назваться данный файл должен config.php в обоих папках.Именно при его отсутствии или если данный файл пуст и будет такая проблема.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.