Перейти к содержанию

Рекомендуемые сообщения

Здравствуйте,

Такая проблема хочу сделать такой слайдер на главной (http://bootsnipp.com/snippets/featured/thumbnail-carousel-single-image-sliding) и решил сделать так взять код который отвечает за вывод картинки и вставить в слайдер (код который хотел вставить)

    <?php if ($banner['link']) { ?>
    <a href="<?php echo $banner['link']; ?>"><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" class="img-responsive" /></a>
    <?php } else { ?>
    <img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" class="img-responsive" />
    <?php } ?>

Чтобы вы понимали что я хочу сделать! я хочу взять php код который отвечает за вывод изображения и вставить в свой слайдер , примерно так .
<div class="col-md-4"> 
<a href="#"><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" class="img-responsive" /></a> 
<div class="text-center">Лікуваня</div> 
</div>

получилось такое:

 

 

здесь я вес обсуждения в па блике по даной теме (https://vk.com/opencartcms?w=wall-56552016_16403%2Fall)

post-719236-0-33272200-1478858765_thumb.jpg

post-719236-0-16203000-1478858767_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Похожий контент

    • От mbhusty
      Привет всем!
      Передали сайт на поддержку, который работает на ocStore 2.3.0.2. 
      По мере разбора возникла проблема с установкой любых модулей. Если по шагам, то происходит так:
      1. Дополнения -> Установка дополнений
      2. Выбираю ранее скаченный необходимый файл
      3. Устанавливаю (ошибок нет)
      4. Дополнения -> Менеджер обновлений -> Обновить
      5. После этого сайт лежит с ошибкой 500, админка работает. Приходится делать откат до предыдущего состояния.
       
      Прошу помочь знающих людей. Гугление особо не помогло, тут на форуме тоже глухо. 
    • От LoneWolf228
      Скачал бэкап магазина. Залил на опенсервер, не открывает и выдаёт ошибки - проблема в базе данных.  Как решить?
    • От magzhan9292
      2018-03-10 0:54:22 - ---------------------------------------------------------------- NOT FOUND! CODE: ~(require|include)(_once)?\(([^)]+)~ FILE: system/library/template/twig.php MOD: Modification Default Не могу найти местонахождения ошибки 
    • От Jonoff
      Здравствуйте ребят! Сегодня обнаружил, что мой сайт стал недоступным. Выдает:
      "This website has been deactivated
      Please contact support"
       
      С чем это может быть связано? Как это можно исправить?
    • От Perleo
      Возникают ошибки .
      Warning: imagecreatetruecolor(): Invalid image dimensions in /var/www/www-root/data/www/МОЙ САЙТ/system/library/image.php on line 105
      Warning: imagecolorallocate() expects parameter 1 to be resource, 
      boolean given in /var/www/www-root/data/www/МОЙ САЙТ/system/library/image.php on line 113
      Warning: imagefilledrectangle() expects parameter 1 to be resource, 
      boolean given in /var/www/www-root/data/www/МОЙ САЙТ/system/library/image.php on line 116
      Warning: imagecopyresampled() expects parameter 1 to be resource, 
      boolean given in /var/www/www-root/data/www/МОЙ САЙТ/system/library/image.php on line 118
       
      В связи с чем ? куда копать ? Помогите исправить
      image.php
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×