Рекомендуемые сообщения

greendruid    0

Добрый день!

 

Подскажите, пожалуйста, как выполнить обновление версии ПО OpenCart с версии 1.5.4.1 до версии 2.0?

 

Попробовал разные методы, но не сработало.

 

1. С помощью следующего скрипта - обновление базы данных идёт и даже есть сообщение о том, что версия (в БД) обновлена, однако при выполнении входа в панель управления я вижу сообщение о том, что версия 1.5.4.1. Может быть я что-то делаю не так? Или это ограничения для скрипта? 

Может быть что-то нужно ещё сделать - подложить файлы новой версии, например?

 

2. С помощью советов по обновлению вручную (здесь и здесь, например). В первом случае у меня не совпадает версия и при выполнении сыпятся ошибки MySQL, а во втором - нужны sql-файлы, содержащие запросы к БД на добавление/удаление или изменение данных (таблиц).

 

Хочу попросить гуру поделиться опытом - как сделать правильно и с минимизацией потерь по времени (простою)? :-)

 

Заранее спасибо за помощь!

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
greendruid    0

Отвечаю самому себе:

1. Обновление возможно! :-)

2. Инструкции по обновлению смотрите здесь (видео на YouTube).

 

Особенно важно отметить:

а) обязательно нужно отключить все расширения! В противном случае обновление DB будет невозможно.

б) конфигурационный файлы, расположенные в / и в /admin разные!

в) скопируйте или перенесите файлы из /images/data в /images/catalog/data ;

г) отключите адреса ссылок "для SEO" из "Панели управления", если не настроен mod_rewrite или правила для Nginx.

Изменено пользователем greendruid

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Похожий контент

    • От Pantelexa
      Здравствуй добрый люд.
      Нужна помощь, при установке любого модуля выдает ошибку.
      Подскажите пожалуйста
      Платформа ОКСТОР 2,1


    • От Gourman
      Здравствуйте, уважаемые продвинутые и начинающие пользователи
      OcStore
       
      В прошлом приобретал платный шаблон под OcStore 1.5.5.1.1, с которым все прекрасно работало.
      Установка проходила без проблем.
      Процесс установки обычно начинается с копирования движка в корневую директорию хостинга,
      после чего при заходе по адресу сайта загружается установщик, который по шагам производит инсталляцию.
       
      Проблема возникла сейчас при попытке установки. В шаге 2 заполняются реквизиты БД,
      в окошке тип БД MySql без вариантов. В настройках веб сервера подключено mysql и mysqli,
      но выбрать в процессе установки можно только mysql
       
      В системных требованиях на странице ocstore.com/downloads требуется "База данных (MySQLi)"
       
      В результате установка обрывается с сообщением об ошибке
       
      Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future:
      Warning: session_start(): Cannot send session cookie - headers already sent by
      Warning: session_start(): Cannot send session cache limiter - headers already sent
      Warning: Cannot modify header information - headers already sent by
       
      Все файлы, которые участвуют в ошибке проверены на UTF-8 без BOM
      в файлах конфигурации отсутствуют пробелы перед началом <?php
       
      В PHP.INI добавлен output_buffering = On
       
      Ошибка продолжает оставаться, останавливая полностью функционирование сайта
      при попытке войти в админку или оформить заказ
       
      Видимо, проблема в выборе драйвера mysql, вместо требуемого mysqli в процессе установки,
      но это единственный вариант, который предлагает установщик.
       
      Просьба, подсказать, есть ли решение подобного вопроса,
      или поделиться опытом, если кто сталкивался
       
       
      Спасибо,
       
       
       
    • От SergeyTur
      Добрый день!
      Подскажите пожалуйста как установить ocStore 2.3.0.2.3
      У меня iMac.
    • От ZRcode

      750.00 руб
      Скачать/Купить дополнение


      ZR code - Mega CSV Import [Opencart 1.5.X - 2.X.X]
      С помощью модуля "ZR code | Mega CSV Import" Вы с лёгкостью сможете импортировать любые прайс-листы в формате csv в Ваш магазин на платформе opencart, так-как данный модуль можно настроить под множество вариаций исходного файла задав значение для каждой колонки Вашего документа.
      Данный модуль позволит Вам импортировать и самому задать категории в которые будут закачиваться товары используя вкладку "Список категорий", также если в Вашем прайс-листе количество указано по типу много, мало и т.д. во вкладке "Настройки количества" Вы сможете сами задать данным значениям численный эквивалент.
      На основной странице модуля находятся следующие настройки:
      Разделитель – позволяет выбрать разделитель использующийся в вашем csv файле Начальная строка – позволяет выбрать строку с которой начнется импорт товаров Строки – используя данную настройку Вы выбираете по сколько строк импортировать за раз (во избежании большой нагрузки на сервер) Тип обновления товара - позволяет выбрать действие для совпадающих товаров (обновить цену, обновить товар, не обновлять) Тип сравнения - (и либо или) позволяет выбрать сравнение товара по заданным Вами значениям в которых совпадают 2 варианта либо же хотя бы 1 Сравнение категорий – категории Вы можете сравнивать по списку либо же значению Сравнения производителей – производителей Вы можете сравнивать по списку либо же значению Добавления в родительские категории – данная опция позволит выбрать добавлять ли товар в родительские категории либо же только в заданную категорию Так же Вы можете выбрать язык товара, Валюту товара, задать фиксированную наценку либо же процент от стоимости для импортируемых товаров, выбрать облагать ли товар налогом или нет. Задать статус товара если его нет в наличии, указать необходим ли ему доставка или нет и стоит ли его вычитать со склада при продаже.
      Во вкладках "Список категорий", "Настройки количества" и "Список производителей" есть возможность импортировать данные на прямую из csv файла.
      Для каждого csv файла можно создать отдельное правило импорта товаров.
      Вы можете импортировать:
      Название Описание Модель Артикул (SKU) Цена Количество Изображение товара Дополнительное изображение товара Категория Идентификатор товара Атрибуты Акционную цену SEO URL Производителей Минимальное количество Размеры товара  
      Поддержка кодировок csv файла: UTF-8 и Windows-1251
       
      Для работы модуля требуется IonCube Loader версии не ниже 5.0 (с PHP не ниже 5.3)!
       
       
      Лицензия у модуля строго на один магазин.
      Инструкция по активации доступна в админке модуля.
      Совместим с версиями opencart: 1.5.X - 2.X.X
      С ув. команда ZR code
      Добавил ZRcode Добавлено 14.04.2016 Категория Обмен данными Системные требования IonCube Loader не ниже 5.0 PHP не ниже 5.3 Сайт разработчика https://zr-code.com Старая цена Метод активации По запросу на почту Ioncube Loader Требуется OpenCart 2.3
      2.2
      2.1
      2.0
      1.5.6.4
      1.5.6.3
      1.5.6.2
      1.5.6.1
      1.5.6
      1.5.4.1
      1.5.3.1 ocStore 2.3
      2.2
      2.1
      1.5.5.1.2
      1.5.5.1.1
      1.5.5.1
      1.5.4.1.2
      1.5.4.1.1
      1.5.4.1
      1.5.3.1
      1.5.2.1
      1.5.1.3 OpenCart.Pro, ocShop  
    • От Klause
      Всех приветствую!
      Есть рабочий магазин udress.ru
      Необходимо обновить движок с последующей установкой шаблона LUXURY.
      Важно сохранить структуру сайта.
      Жду предложений в ЛС. Стоимость/Сроки
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу