Перейти к содержанию
jugj

[Решено] ошибка cURL

Рекомендуемые сообщения

Не новичок, но одна проблема грузит. При установке опенкарт на локальный сервер бьет ошибку cURL. Модуль в папке есть в ини включен. Не пойму в чем лажа. Не денвер. Апач -2.4.6-win64. PHP 5.4 . Ставлю опенкарт 2.0.3.1 . Винда 10.

Изменено пользователем jugj

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

php.ini - раскомментируйте строку extension=php_curl.dll или установите Open Server место Апач -2.4.6-win64

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

php.ini - раскомментируйте строку extension=php_curl.dll или установите Open Server место Апач -2.4.6-win64

Не хочу показаться невежливым, но, народ, пожалуйста читайте внимательно вопрос. 

Модуль в папке есть в ини включен.

 

Если вы не поняли расшифровываю. Ини это значит ини-файл PHP (ini.php), а сие означает что что строка раскоментирована.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

может это или это поможет

 

сам - не сталкивался, давно уже использую openserver (в связке с virtualbox)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

может это или это поможет

 

сам - не сталкивался, давно уже использую openserver (в связке с virtualbox)

Дело в том что у меня необходимые настройки включены (Required Settings : on) а вот текущие нет (Current Settings : off). Как это понимать?

Изменено пользователем jugj

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

может это или это поможет

 

сам - не сталкивался, давно уже использую openserver (в связке с virtualbox)

Библиотек в систем не было, но копирование туда dll не помогло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Required Settings : on / Current Settings : off

по-русски ведь написано :-) - "требуется : ВКЛ / в данный момент : ВЫКЛ"

Библиотек в систем не было, но копирование туда dll не помогло.

шта?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis, Интересно как Вы это себе представляете. Пальцем тыкнуть что ли? Если в PHP.ini строка раскоментирована. Где еще включить? Я не просил здесь высказываться водолеев. Ждал конкретной помощи. А здесь вижу её не найти.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всем спасибо, разобрался. Действительно была не включена библиотека кривизна апача и PHP. Поставил другую версию и все заработало. Если кому интересно отпишусь. Всем спасибо за помощь!!!!

:eek:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.