Jump to content
Sign in to follow this  
fatalex

И снова проблема

Recommended Posts

Проблема в следующем, после редактировки htaccess (внесение RewriteRule ^download/(.*) index.php?route=error/not_found [L]

RewriteRule ^upload/(.*) index.php?route=error/not_found [L]) Перестала отображаться главная страница. Вернул как было...
 
Теперь выкидывает:
 Notice: Undefined index: token in /docs/admin/controller/error/not_found.php on line 16Notice: Undefined index: token in docs/admin/controller/error/not_found.php on line 22
 
Проверил оба конфига, всё вроде норм, оба идентичны:
<?php
// HTTP
define('HTTP_SERVER', 'http://pribor.ru/admin/');
define('HTTP_CATALOG', 'http://pribor.ru/');
define('HTTP_IMAGE', 'http://pribor.ru/image/');
 
// HTTPS
define('HTTPS_SERVER', 'http://pribor.ru/admin/');
define('HTTPS_CATALOG', 'http://pribor.ru/');
define('HTTPS_IMAGE', 'http://pribor.ru/image/');
 
// DIR
define('DIR_APPLICATION', '/home/servis/pribor.ru/docs/admin/');
define('DIR_SYSTEM', '/home/servis/pribor.ru/docs/system/');
define('DIR_DATABASE', '/home/servis/pribor.ru/docs/system/database/');
define('DIR_LANGUAGE', '/home/servis/pribor.ru/docs/admin/language/');
define('DIR_TEMPLATE', '/home/servis/pribor.ru/docs/admin/view/template/');
define('DIR_CONFIG', '/home/servis/pribor.ru/docs/system/config/');
define('DIR_IMAGE', '/home/servis/pribor.ru/docs/image/');
define('DIR_CACHE', '/home/servis/pribor.ru/docs/system/cache/');
define('DIR_DOWNLOAD', '/home/servis/pribor.ru/docs/download/');
define('DIR_LOGS', '/home/servis/pribor.ru/docs/system/logs/');
define('DIR_CATALOG', '/home/servis/pribor.ru/docs/catalog/');
 
// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'servis.mysql');
define('DB_USERNAME', 'servis_alex');
define('DB_PASSWORD', 'pass');
define('DB_DATABASE', 'servis_nflu');
define('DB_PREFIX', '');
?>
 
 
Что ещё может быть??? Требуется помощь
Edited by fatalex

Share this post


Link to post
Share on other sites

htaccess:

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 
 
# 2. In your opencart directory rename htaccess.txt to .htaccess.
 
# For any support issues please visit: http://www.opencart.com
 
Options +FollowSymlinks
 
# Prevent Directoy listing 
Options -Indexes
 
# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>
 
# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 
 
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
 
### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.
 
# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals On
 
# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc On
 
# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M
 
# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M
 
# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200
 
# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

Share this post


Link to post
Share on other sites

конфиги НЕ ДОЛЖНЫ быть идентичны.

Share this post


Link to post
Share on other sites

что должно быть в конфиге в папке admin? в чём отличие? Файл старый потёр к несчастью... Есть образец конфига?

Share this post


Link to post
Share on other sites

Поставьте чистую cms и посмотрите какие пути точно должны быть. (только бекап сделать не забудьте)

Share this post


Link to post
Share on other sites

поправил конфиги опираясь на образцы, в админку теперь влетаю, но показывает пустую страницу, т.е. не отображает сайт, ошибок не выдаёт, просто пустая белая страница, по настройкам php всё норм... Может ещё что-то поправить, хостер nic.ru?

Share this post


Link to post
Share on other sites

проверить наличие ошибок в system/log/error.txt

Share this post


Link to post
Share on other sites

Поставил отображение ошибок словил:

Fatal error: require_once() [function.require]: Failed opening required '/home/hosting/site.ru/system/startup.php' (include_path='.:/home/hosting/site.ru/php') in /home/hosting/docs/index.php on line 19

Share this post


Link to post
Share on other sites

on line 19 у нас :

// VQMODDED Startup

 require_once($vqmod->modCheck(DIR_SYSTEM . 'startup.php'));

Share this post


Link to post
Share on other sites

Ну и вспоминай куда дел startup.php

и кстати почему изменились все пути.

Edited by nikifalex

Share this post


Link to post
Share on other sites

на месте они, я их не трогал... Проблемы начались, после внесения в htaccess 2-х строчек и последующего их удаления...

Уже всю голову себе сломал и все настройки перекрутил... х.з. что ещё делать...

Share this post


Link to post
Share on other sites

1)

 

конфиги отличаются и делятся соответственно на две части:

тот, который в корне папки opencart - для магазина (витрины, фронтенда)

тот, что в папке admin - для админки

 

их содержимое визуально похоже, но есть отличия

тот, который вверху привели - это конфиг админки admin/config.php

 

для витрины конфиг в корне должен быть таким:

<?php
// HTTP
define('HTTP_SERVER', 'http://pribor.ru/');
 
// HTTPS
define('HTTPS_SERVER', 'http://pribor.ru/');
 
// DIR
define('DIR_APPLICATION', '/home/servis/pribor.ru/docs/catalog/');
define('DIR_SYSTEM', '/home/servis/pribor.ru/docs/system/');
define('DIR_DATABASE', '/home/servis/pribor.ru/docs/system/database/');
define('DIR_LANGUAGE', '/home/servis/pribor.ru/docs/catalog/language/');
define('DIR_TEMPLATE', '/home/servis/pribor.ru/docs/catalog/view/template/');
define('DIR_CONFIG', '/home/servis/pribor.ru/docs/system/config/');
define('DIR_IMAGE', '/home/servis/pribor.ru/docs/image/');
define('DIR_CACHE', '/home/servis/pribor.ru/docs/system/cache/');
define('DIR_DOWNLOAD', '/home/servis/pribor.ru/docs/download/');
define('DIR_LOGS', '/home/servis/pribor.ru/docs/system/logs/');
 
// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'servis.mysql');
define('DB_USERNAME', 'servis_alex');
define('DB_PASSWORD', 'pass');
define('DB_DATABASE', 'servis_nflu');
define('DB_PREFIX', '');
?>

 

2) НИКОГДА не выкладывайте на всеобщее обозрение часть с DB из конфигов - там доступ к вашей БД

срочно меняйте сейчас

Share this post


Link to post
Share on other sites

1) Поменял уже... результат тот же, в админку захожу норм, сайт сыпет :

Warning: require_once(/home/рщыештп/site.ru/system/startup.php) [function.require-once]: failed to open stream: No such file or directory in /home/hosting/site.ru/docs/index.php on line 19

Fatal error: require_once() [function.require]: Failed opening required '/home/hosting/site.ru/system/startup.php' (include_path='.:/home/hosting/site.ru/php') in /home/hosting/site.ru/docs/index.php on line 19

 

2) Это разумеется ненастоящие конфиги BD)))

Edited by fatalex

Share this post


Link to post
Share on other sites

чудес не бывает, смотрите конфиги

вот подобная тема

Share this post


Link to post
Share on other sites

Прошёлся ещё раз по конфигам всё вроде норм, точно в корневом конфиге не нужны строчки HTTP_IMAGE и CATALOG?

Share this post


Link to post
Share on other sites

Перепроверил все конфиги

в руте

// HTTP
define('HTTP_SERVER', 'http://pribor.ru/');
define('HTTP_IMAGE', 'http://pribor.ru/image/');

// HTTPS
define('HTTPS_SERVER', 'http://pribor.ru/');
define('HTTPS_IMAGE', 'http://pribor.ru/image/');

// DIR
define('DIR_APPLICATION', '/home/servis/pribor.ru/docs/catalog/');
define('DIR_SYSTEM', '/home/servis/pribor.ru/docs/system/');
define('DIR_DATABASE', '/home/servis/pribor.ru/docs/system/database/');
define('DIR_LANGUAGE', '/home/servis/pribor.ru/docs/catalog/language/');
define('DIR_TEMPLATE', '/home/servis/pribor.ru/docs/catalog/view/template/');
define('DIR_CONFIG', '/home/servis/pribor.ru/docs/system/config/');
define('DIR_IMAGE', '/home/servis/pribor.ru/docs/image/');
define('DIR_CACHE', '/home/servis/pribor.ru/docs/system/cache/');
define('DIR_DOWNLOAD', '/home/servis/pribor.ru/docs/download/');
define('DIR_LOGS', '/home/servis/pribor.ru/docs/system/logs/');

 

в admin

// HTTP
define('HTTP_SERVER', 'http://pribor.ru/admin/');
define('HTTP_CATALOG', 'http://pribor.ru/');
define('HTTP_IMAGE', 'http://pribor.ru/image/');

// HTTPS
define('HTTPS_SERVER', 'http://pribor.ru/admin/');
define('HTTPS_CATALOG', 'http://pribor.ru/');
define('HTTPS_IMAGE', 'http://pribor.ru/image/');

// DIR
define('DIR_APPLICATION', '/home/servis/pribor.ru/docs/admin/');
define('DIR_SYSTEM', '/home/servis/pribor.ru/docs/system/');
define('DIR_DATABASE', '/home/servis/pribor.ru/docs/system/database/');
define('DIR_LANGUAGE', '/home/servis/pribor.ru/docs/admin/language/');
define('DIR_TEMPLATE', '/home/servis/pribor.ru/docs/admin/view/template/');
define('DIR_CONFIG', '/home/servis/pribor.ru/docs/system/config/');
define('DIR_IMAGE', '/home/servis/pribor.ru/docs/image/');
define('DIR_CACHE', '/home/servis/pribor.ru/docs/system/cache/');
define('DIR_DOWNLOAD', '/home/servis/pribor.ru/docs/download/');
define('DIR_LOGS', '/home/servis/pribor.ru/docs/system/logs/');
define('DIR_CATALOG', '/home/servis/pribor.ru/docs/catalog/');

Безрезультатно(

В админку влезаю норм, сайт не отображается

Share this post


Link to post
Share on other sites

Ура заработало!!! Причина банальна, оказалось, что в настройках админки кто-то тупо поменял шаблон, а я тут ковырялся с настройками php)

Всем огромное спасибо!!!

Share this post


Link to post
Share on other sites

Вылез новый трабл, Image Manager лезет не в папку image как раньше, а в /admin... Где настроить папку по умолчанию...?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.