OnL1ne

Ошибка Mysql при обновлении

Рекомендуемые сообщения

OnL1ne    0

Решил протестировать обновление версии OpenCart c v1.5.3.1 на 1.5.5.1.2 и столкнулся с такой ошибкой....  выполнил такие вот действия: 

ШАГ 1. BACKUP: Сделайте копию существующих файлов магазина и базы данных!
 
ШАГ 2. Загрузите все новые файлы поверх текущей установки КРОМЕ config.php и admin/config.php
 
ШАГ 3. Откройте http://www.yourstore.com/shop/install (папку install в корне магазина)
 
ШАГ 4. Установщик должен направить Вас к процессу обновления. Если вы видите шаги установки, значит Вы переписали ваши файлы конфигурации (config). Восстановите их, так как обновление нуждается в существующих config.php и admin/config.php файлах.
 
ШАГ 5. Нажмите кнопку "Обновить". Через несколько секунд вы должны увидеть страницу успешного обновления. Выполните следующие действия, следуя инструции
 
ШАГ 6. Сообщите о любой ошибке обновления на форуме.

 

( ! ) Fatal error: Maximum execution time of 60 seconds exceeded in D:\OpenServer\domains\localhost\ocstore\system\database\mysql.php on line 22Call Stack#TimeMemoryFunctionLocation10.0000364168{main}( )..\index.php:020.01401101584Front->dispatch( )..\index.php:7830.01401101584Front->execute( )..\front.php:2940.01501125272call_user_func_array:{D:\OpenServer\domains\localhost\ocstore\system\engine\front.php:42} ( )..\front.php:4250.01501125408ControllerUpgrade->index( )..\front.php:4260.02701249384ModelUpgrade->mysql( )..\upgrade.php:9759.67943585976DB->query( )..\upgrade.php:229859.67943585976MySQL->query( )..\db.php:16

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    1 919
обновление версии OpenCart c v1.5.3.1 на 1.5.5.1.2

 

 

подразумевает обновление всеми промежуточными версиями.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
OnL1ne    0

подразумевает обновление всеми промежуточными версиями.

Всмысле? для того чтобы обновить версию нужно установить по очереди каждую вышедшую после или как? можно подробней, 1 раз это делаю....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    1 919

Именно так.Все по очереди.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
OnL1ne    0

Именно так.Все по очереди.

Ок, Сделал заного.... поставил: ocstore-1.5.3.1, обновил нормально до ocstore-1.5.4.1.2. проверил, все работало, начал обновлять с ocstore-1.5.4.1.2 до ocstore-1.5.5.1.1 и опять тоже самое - Вуаля :

 

 

( ! ) Fatal error: Maximum execution time of 60 seconds exceeded in D:\OpenServer\domains\localhost\ocstore\system\database\mysql.php on line 22Call Stack#TimeMemoryFunctionLocation10.0900364424{main}( )..\index.php:020.10301102176Front->dispatch( )..\index.php:7830.10301102176Front->execute( )..\front.php:2940.13701125864call_user_func_array:{D:\OpenServer\domains\localhost\ocstore\system\engine\front.php:42} ( )..\front.php:4250.13701126000ControllerUpgrade->index( )..\front.php:4260.14001249968ModelUpgrade->mysql( )..\upgrade.php:9759.80643588808DB->query( )..\upgrade.php:301859.80643588808MySQL->query( )..\db.php:16

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
OnL1ne    0

Все разобрался, 1.5.5.1.1 и 1.5.5.1.2  install запускать не нужно, просто копируем и все....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу