Jump to content
Sign in to follow this  
Damat

Неработают некоторые отчеты в админке

Recommended Posts

В админке не работает этот отчет, точнее пустой:

 

Отчет по просмотренным товарам - Нет данных!

 

Где нужно порыться что бы он заработал? ocStore 1.5.5.1.1

Share this post


Link to post
Share on other sites

Все такие скромные на форуме.

Очень нужно разобраться с этой проблемой.

Помогите!

Share this post


Link to post
Share on other sites

Где нужно порыться что бы он заработал? ocStore 1.5.5.1.1

Нигде, должно работать сразу.

Отчет не работал сразу после установки или вы какие-то действия проводили с магазином, после чего заметили проблему?

Share this post


Link to post
Share on other sites

После установки работало, заметил когда сделал сброс отчета. И больше он не считает.

вырезал с категориии, производители , акции, с модулей последнии и рекомендуемые этот код:





<?php if ($product['rating']) { ?>

<div class="rating"><img src="catalog/view/theme/default/image/stars-<?php echo $product['rating']; ?>.png" alt="<?php echo $product['reviews']; ?>" /></div>

<?php } ?>

ставил vQmod  модуль симла упрощенная регистрация только он заменил системный файл./system/library/url.php

Вроде все. 

Заметил поздно, работы много сделал. Иначе бы все снес и заново поставил.

Share this post


Link to post
Share on other sites

Очевидно, что причина кроется в изменениях. Не могу подсказать в чем конкретно дело, но на вашем месте я бы вспоминал что и где конкретно менял и сравнивал бы с оригинальными файлами движка.

Share this post


Link to post
Share on other sites

Сделал бэкап базы и всего магазина, перенес на тестовый сервер (там магазин и создавался), и мистика, счетчик работает.

 

Перенос делаю так:

Сделать экспорт Базы данных если там есть нужные данные
Вставить папку install в корневую папку магазина( папка install должна быть от той версии которой и сам магазин)
Вычистить оба конфига( то есть удалить всё инфу в них)
Сделать чистую установку( то есть после этих действий открыть ссылку на свой магазин и увидить процесс установки)
После УСТАНОВКИ
Зайти в Базу Данных
Выделить все таблицы
и
УДАЛИТЬ(этим мы удаляем БД только что созданную)

Последний пункт

Нажать импорт и выбрать файл с той БД которую до этого мы Экспортировали

 

Помогите нубу решить проблему.

Share this post


Link to post
Share on other sites

Разобрался я со своей проблемой

 

В файле reviews-stars-v2.1.xml модуля современые отзывы
где то в 440 строке было так:



<operation>
<search position="replace" error="log"><![CDATA[

Заработало так:

<operation>
<search position="after" error="log"><![CDATA[

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.