Перейти к содержанию
Marusia

Версия Opencart, как предмет раздумий!

Рекомендуемые сообщения

Здравствуйте форумчане!

 

Я уже заранее предполагаю, что вопрос мой покажется банальным, но все же, гуглила и не нагуглила, на форуме нашла старую тему. Собственно говоря, какую версию Opencart или Ocstore поставить, что бы не получилось так, что большинство модулей придется покупать. Не в обиду разработчикам, которые трудятся и продают свои модули. Думаю установить 1.5.4.1 но смотрю, что вышла уже 1.5.5.1 но модулей по моему больше на 1.5.4.1, а если компнуть глубже, то вообще 1.5.3.1 модулей дофика. 

 

 

Люди добрые, христа ради, давайте обсудим эту тему и пусть каждый скажет свое мнение. 

 

P.S. Хочу, что бы все работало и находилось )

 

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

обсуждали уже. ставьте последнюю ocStore

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

обсуждали уже. ставьте последнюю ocStore

 

Уважаемый Фрилансер, если не трудно, киньте ссылочку на такое обсуждение :) 

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость brk

Уважаемый Фрилансер, если не трудно, киньте ссылочку на такое обсуждение :)

Миледи..

Ставьте 1.5.4.1.2... лучше.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Миледи..

Ставьте 1.5.4.1.2... лучше.

 

А чем объяснить такой выбор?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вы видели эту страницу?

https://opencartforum.com/topic/25354-релиз-ocstore-v15511/?do=findComment&comment=194561

читали сколько всего было добавлено в последнюю версию?

если автор поддерживает своё дополнение, он в любом случае позаботится о поддержке последней версии иначе зачем вам такое дополнение?

  • +1 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вы видели эту страницу?

https://opencartforum.com/topic/25354-релиз-ocstore-v15511/?do=findComment&comment=194561

читали сколько всего было добавлено в последнюю версию?

если автор поддерживает своё дополнение, он в любом случае позаботится о поддержке последней версии иначе зачем вам такое дополнение?

Да уж, работы проделано много. Я уже поставила последнюю версию Ocstore. А по поводу поддержки авторами своих дополнений я и не заморачивалась как то)) думал ну главное что бы было и работало))) а будет оно обновляться это дело уже десятое)))

 

Спасибо за сылку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Либо я дурак, либо одно из двух...

Такое ощущение, что все вокруг знают, а только мне забыли сообщить: ocStore и Open Cart - это одно и то же или разные вещи???

Просветите кто-нибудь, будьте так добры! А то пишут: "... для 1.5.4.1" - и то одно из этих слов, то другое, а то и вовсе никакого, только цифры. Вот и гадай: подойдет - не подойдет...:(

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Либо я дурак, либо одно из двух...

Такое ощущение, что все вокруг знают, а только мне забыли сообщить: ocStore и Open Cart - это одно и то же или разные вещи???

Просветите кто-нибудь, будьте так добры! А то пишут: "... для 1.5.4.1" - и то одно из этих слов, то другое, а то и вовсе никакого, только цифры. Вот и гадай: подойдет - не подойдет... :(

 

Open Cart - это официальная CMS, а ocStore - это наши локализовали ее на родной русский язык. Я качаю для 1.5.4.1 и не важно, что пишут  ocStore или Open Cart, все работает и на той и на той сборке. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Open Cart - это официальная CMS, а ocStore - это наши локализовали ее на родной русский язык. Я качаю для 1.5.4.1 и не важно, что пишут  ocStore или Open Cart, все работает и на той и на той сборке. 

Ой, спасибо огромное, добрый человек! Наконец-то внятная информация по этому поводу. :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ой, спасибо огромное, добрый человек! Наконец-то внятная информация по этому поводу. :)

Остается загадкой, как вы пропустили тему с описанием отличий

 

Разница между ocStore v1.5.5.1 и оригинальным OpenCart v1.5.5.1:

 

Локализация:

  • Добавлен русский языковой пакет;
  • Локализация базы (схемы, статусы, возвраты).

SEO:

  • Добавлены title и h1 для товаров и категорий;
  • Для статей добавлены title, h1, meta keywords и meta description;
  • Для производителей добавлены title, h1, meta keywords, meta description и description;
  • Добавлен альтернативный метод формирования ЧПУ исключающий формирование разных ссылок для одной страницы;
  • Исправлены генераторы Sitemap и Google Base;
  • Добавлено url alias для базовых страниц
  • В логотипе на главной убрано ссылку на саму себя
  • Убрано скрытый H1 в home.tpl
  • Заменен блок поделится на странице продукта

Оптимизация:

  • Оптимизирован алгоритм формирования списка категорий в административной части;
  • Изменён алгоритм отображения списка категорий в административной части;
  • FIX error file-type log
  • Добавил show/hide в форме редактирования товара, для скрытия ненужных полей ISBN и т.д.
  • Ускорение работы OpenCart - не вычислять кол-во товаров в категории, если в настойках стоит не показывать. Подсчет кол-ва товаров средствами SQL_CALC_FOUND_ROWS

Расширение функционала:

  • Добавлена отправка SMS уведомлений;
  • Добавлена возможность выбирать группу покупателей назначаемой при регистрации;
  • Добавлено отображение активного пункта в горизонтальном меню;
  • Задание ключа Google API через систему администрирования;
  • Библиотека ocstore с методом проверки переменных (filter_val - в основном для проверки email) , для корректной валидации кириллических доменов.
  • Добавлено полезные инструменты от OC Team
  • Кэш изображений image/cache создается с преобразованием русских букв и пробелов в латиницу и дефисы.
  • Отображение названия товара в заголовке при его редактировании
  • Стилизация списков в административной части 
  • Фото товара no-image.jpg на странице товара и в категории
  • Фильтр по категории и производителю в списке товаров в административной части
  • GeoIP от Google. Для включения надо в настройках магазина указать ключ Google API
  • В форме редактирования заказа в админке способы доставки, содержащие HTML-тэги теперь нормально показываются в выпадающем списке и нормально сохраняются, без экранирования тэгов.

Изменено:

  • Стилизация списков в административной части
  • Стилизация фронтальной части

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все таки лучше начать с того что Вы хотите сделать, ну а потом обсудить на чем это лучше сделать.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Мда... если бы я даже эту тему увидела (видно, в толпе она затерялась, тут много же разного) - это мне не поможет. Куча непонятных подробностей преобразования чего-то куда-то...

У меня другая ситуация: магазин уже работает на Open Cart 1.5.4.1 - ну так исторически сложилось.

И требуется различать, что к нему можно прикрутить, а что - не следует.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Остается загадкой, как вы пропустили тему с описанием отличий

 

Разница между ocStore v1.5.5.1 и оригинальным OpenCart v1.5.5.1:

 

Локализация:

  • Добавлен русский языковой пакет;
  • Локализация базы (схемы, статусы, возвраты).

SEO:

  • Добавлены title и h1 для товаров и категорий;
  • Для статей добавлены title, h1, meta keywords и meta description;
  • Для производителей добавлены title, h1, meta keywords, meta description и description;
  • Добавлен альтернативный метод формирования ЧПУ исключающий формирование разных ссылок для одной страницы;
  • Исправлены генераторы Sitemap и Google Base;
  • Добавлено url alias для базовых страниц
  • В логотипе на главной убрано ссылку на саму себя
  • Убрано скрытый H1 в home.tpl
  • Заменен блок поделится на странице продукта

Оптимизация:

  • Оптимизирован алгоритм формирования списка категорий в административной части;
  • Изменён алгоритм отображения списка категорий в административной части;
  • FIX error file-type log
  • Добавил show/hide в форме редактирования товара, для скрытия ненужных полей ISBN и т.д.
  • Ускорение работы OpenCart - не вычислять кол-во товаров в категории, если в настойках стоит не показывать. Подсчет кол-ва товаров средствами SQL_CALC_FOUND_ROWS

Расширение функционала:

  • Добавлена отправка SMS уведомлений;
  • Добавлена возможность выбирать группу покупателей назначаемой при регистрации;
  • Добавлено отображение активного пункта в горизонтальном меню;
  • Задание ключа Google API через систему администрирования;
  • Библиотека ocstore с методом проверки переменных (filter_val - в основном для проверки email) , для корректной валидации кириллических доменов.
  • Добавлено полезные инструменты от OC Team
  • Кэш изображений image/cache создается с преобразованием русских букв и пробелов в латиницу и дефисы.
  • Отображение названия товара в заголовке при его редактировании
  • Стилизация списков в административной части 
  • Фото товара no-image.jpg на странице товара и в категории
  • Фильтр по категории и производителю в списке товаров в административной части
  • GeoIP от Google. Для включения надо в настройках магазина указать ключ Google API
  • В форме редактирования заказа в админке способы доставки, содержащие HTML-тэги теперь нормально показываются в выпадающем списке и нормально сохраняются, без экранирования тэгов.

Изменено:

  • Стилизация списков в административной части
  • Стилизация фронтальной части

 

Мы говорили про 1.5.4.1 там конечно то же много отличий, но человека интересовала инфа, какие модули ему качать если к примеру у него OcStore 1.5.4.1 а модуль, который он нашел и хочет скачать для линейки к примеру 1.5.4.1 или еще как пишут 1.5.х , я и ответила, что качаю для 1.5.4.1 модули и они у меня работают отлично на любой сборке этой версии. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ищущий да обрящет

5й пост в этой теме

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все таки лучше начать с того что Вы хотите сделать, ну а потом обсудить на чем это лучше сделать.

 

 

Хотим магазин и бесплатных модулей, да по больше по больше!!! )))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Мда... если бы я даже эту тему увидела (видно, в толпе она затерялась, тут много же разного) - это мне не поможет. Куча непонятных подробностей преобразования чего-то куда-то...

У меня другая ситуация: магазин уже работает на Open Cart 1.5.4.1 - ну так исторически сложилось.

И требуется различать, что к нему можно прикрутить, а что - не следует.

качайте модули,  в которых подписано для 1.5.4.1 или для 1.5.х то же работают, во всяком случае у меня и та и та сборка 1.5.4.1 и все модули работают)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Форум Дополнения бесплатно Вам туда!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Форум Дополнения бесплатно Вам туда!

Понятно что туда)) человеку не понятно подойдет модуль если подписано, что для версии OcSrore 1.5.4.1, а у него стоит Open Cart 1.5.4.1  Уууууууёёёёёёё

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Понятно что туда)) человеку не понятно подойдет модуль если подписано, что для версии OcSrore 1.5.4.1, а у него стоит Open Cart 1.5.4.1  Уууууууёёёёёёё

 

 

 

Читать то умеем???? OcSrore и Open Cart  разница есть??? А остальное на свой страх и риск! Вот и Уууууууёёёёёёё

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Читать то умеем???? OcSrore и Open Cart  разница есть??? А остальное на свой страх и риск! Вот и Уууууууёёёёёёё

а почему бы вам не ответить, примерно так: Вы можете устанавливать модули для версии OcSrore 1.5.4.1 на Open Cart 1.5.4.1 и на оборот, на свой страх и риск. И ваще никакх вопросов. А то умничаете, про разницы тут нам толкуете ссылками.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а почему бы вам не ответить, примерно так: Вы можете устанавливать модули для версии OcSrore 1.5.4.1 на Open Cart 1.5.4.1 и на оборот, на свой страх и риск. И ваще никакх вопросов. А то умничаете, про разницы тут нам толкуете ссылками.

 

 

Понятно что туда)) человеку не понятно подойдет модуль если подписано, что для версии OcSrore 1.5.4.1, а у него стоит Open Cart 1.5.4.1  Уууууууёёёёёёё

 

 

Какой вопрос такой ответ!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Держу магазин на этом движке уже 3 года. Начинал с версии 0.2.чего-то там... стараюсь обновлять магазин с каждым выходом новой версии. Проблем с модулями не было никогда. Обычно авторы модулей либо сами обновляют свои модули, либо делают это по просьбе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.