zsv

Не правильно отображается сайт в браузере

Рекомендуемые сообщения

zsv    0

Установил ocstore_v0.1.7 , захожу на сайт отображается абра кодабра , когда меняю кодировку на юникод UTF-8 все нормально отображается,

как только обновлю страницу сайт снова отображается вот с таким текстом :

Р ”обСЂРѕ пожалРњРѕР№ Р С�Р °Р С–Р °Р ·Р ёРЅ!

Добро пожаловать в Мой магазин

Такой же текс в админке там где указывается Регион / Область (название областей отображается так же ): овать РІ РњРѕР№ магазин

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
UncleAndy    16

Установил ocstore_v0.1.7 , захожу на сайт отображается абра кодабра ,

Рекомендую поправить настройки сайта на сервере http (nginx или apache) - в нем тоже может указываться кодировка. Скорей всего, неверная кодировка выдается сервером броузеру в заголовках ответа.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
zsv    0

Рекомендую поправить настройки сайта на сервере http (nginx или apache) - в нем тоже может указываться кодировка. Скорей всего, неверная кодировка выдается сервером броузеру в заголовках ответа.

спасибо, помогло..))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
aachernishev    38

Рекомендую поправить настройки сайта на сервере http (nginx или apache) - в нем тоже может указываться кодировка. Скорей всего, неверная кодировка выдается сервером броузеру в заголовках ответа.

Спасибо, та же проблема была в firefoxе =)

+1

в файле .htaccess просто добавил :

AddDefaultCharset utf-8
Изменено пользователем aachernishev

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
real56    0

Таже проблема но так я и не понел что нужно сделать разжуйте плиз

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
real56    0

как и куда надо вписать AddDefaultCharset utf-8 ????

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
dim565    14

real56, выше ж писали, что в htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
real56    0

real56, выше ж писали, что в htaccess

ну я пробовал там чтото написано что прямо в конец надписи? непомогает. может что не так делаю

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
dim565    14

расширение txt убрали у htaccess?

Вот еще что нашел в гугле:

В корневой директории форума создайте файл .htaccess со следующим содержанием:

.htaccess

CharsetDisable On
CharsetDefault UTF-8 
CharsetSourceEnc UTF-8

Если после этого теряется работоспособность ресурса, попробовать убрать из вышеуказанного кода строку

CharsetDisable On

Если не помогает, то вместо первого попробовать добавить в .htaccess строку

AddDefaultCharset UTF-8

Если у хостера Russian Apache попробуйте добавить в .htaccess

CharsetDisable On
AddHandler default-handler html
CharsetDefault utf-8

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
real56    0

расширение txt убрали у htaccess?

Вот еще что нашел в гугле:

ВВёл 3 строчки error500

Убрал верхнюю ВСЁ ОК!!!!!!!!!!

Большое спасибо!!!!! Сутки от компа не оходил ВСЮ БДмайсикюл изучил а ответ был рядом ))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
letun    1

А я как только убрал расширение txt так 500 ошибка и всё...как быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу