Перейти к содержанию
pinskiy

[РЕШЕНО] Поиск не реагирует ни на что

Рекомендуемые сообщения

Здравствуйте.

Возникла проблемная ситуация. Был интернет-магазин, который работал нормально, но в один момент там случился редизайн (о чем я не знал и шапка была переверстана). В итоге: поиск висит мертвым грузом и ни на что не реагирует, т.е. он даже не форма поиска, а непонятно что. В чем может быть проблема? Сталкивался кто-нибудь? И еще такой вопрос, как можно стандартный поиск заставить искать не только по брендам, но и в описаниях?

search.php

stylesheet.css

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а ссылку на сайт можно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

я чуть выше написал (только неактивной сделал) www.shop.zapusk.by. Я хотел еще сюда ява-скрипты выложить, но форум сказал, что у меня прав нет на это.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

посмотрите в header.tpl темы оформления default, как реализуется поиск.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Смотрел. Не просто смотрел, но даже целые куски кода, отвечающего за поиск, из дефолтного хедера ставил в этот переверстанный - не помогло. У меня есть тестовый сайт, на нем все нормально работало, поставил их хедер - поиск лег. Понятно, что что-то не так с их хедером, но я уже столько времени в его расковыривании провел, что глаз "замылился" и не могу понять, что именно я упускаю.

Вот как в header.tpl вывод поиска реализован:

<div id="search">
   <div class="button-search"></div>
   <?php if ($filter_name) { ?>
   <input type="text" name="filter_name" value="<?php echo $filter_name; ?>" />
   <?php } else { ?>
   <input type="text" name="filter_name" value="<?php echo $text_search; ?>" onclick="this.value = '';" onkeydown="this.style.color = '#000000';" />
   <?php } ?>
 </div>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

версию не указали, поэтому я отослал вас в 149x

если у вас 15х - откройте

catalog/view/javascript/common.js

в самом верху два блока - обработка поиска.

у вас как минимум ID не header

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Большое спасибо! Действительно, проблема была в том, что верстальщик изменил id div'а, в котором находилась форма поиска и common.js банально потерял с ней связь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.