Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Решено] Пустой символ перед !DOCTYPE на внутренних страницах


Silm
 Share

Recommended Posts

На некоторых внутренних страницах перед <!DOCTYPE html> отображается некий пустой символ (его видно только в просмотре исходного кода в експлорере, выглядит как табуляция, но не копируется), это приводит к тому, что в експлорере и хроме едет верстка (отображается пустая строка в самом верху страницы), что логично, ибо по спецификации перед <!DOCTYPE html> ничего быть не должно.

Что самое странное на главной странице а также некоторых других страницах (на пример на странице регистрации) перед <!DOCTYPE html> все чисто. Откуда может появляться этот символ?

Link to comment
Share on other sites


Разобрался. В общем то про BOM подумал сразу, проверил редактированные мной файлы, все было в порядке. Оказалось что кто то до меня редактировал несколько языковых файлов и сохранил их в UTF-8 With BOM...

Если кто то столкнется с похожей проблемой, попробуйте сделать копию всего проекта и прогнать папку через утилиту utf-8 BOM Remower с установленной галочкой на логирование. Потом посмотреть лог выданный утилитой, там будет написано если файлы с BOM нашлись, как и решение задачи.

Link to comment
Share on other sites


Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.