Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Не могу найти причину ошибки


Recommended Posts

Добрый день, перенесли сайт с одного хостинга на другой, и стала вылетать ошибка при сохранении "шаблона цветов", так же не создает новые шаблоны, но редактировать старые можно, но ошибка всё равно вылетает. Так же я его переписал на версию 3.0.2.0 изначально он бы на 2.3 версии
Notice: Undefined index: sort in /home/k/**/**/public_html/admin/model/catalog/color.php on line 11Warning: Cannot modify header information - headers already sent by (output started at /home/k/*/**/public_html/admin/controller/startup/error.php:34) in /home/k/**/**/public_html/system/library/response.php on line 36
Модуль сам 

переделанный под версию 3.0.2.0 во вложении

В чем может быть проблема? 
Можно просто указать где и что проверить, а дальше я сам как-нибудь... Но если найдете причину - будет вообще замечательно,
Помогите пожалуйста.
Спасибо

colors.ocmod.zip

Link to comment
Share on other sites


ну временно решил проблему, поставив условие проверки на переменную в файле admin/model/catalog/color.php 
 

		if (isset($data['option_value'])) {
			foreach ($data['option_value'] as $r_option) {
				if(isset($r_option['sort'])){
					$sort = $r_option['sort'];
				} else {
					$sort = 0;
				}
				$this->db->query("INSERT INTO " . DB_PREFIX . "color_options SET option_id = '" . (int)$r_option['option_id'] . "', color = '" . $this->db->escape($r_option['color']) . "', sort = '" . $sort . "'");
				
				$option_id = $this->db->getLastId();
				
				foreach ($r_option['r_opt_description'] as $language_id => $r_opt_description) {
					$this->db->query("INSERT INTO " . DB_PREFIX . "color_options_description SET option_id = '" . (int)$option_id . "', language_id = '" . (int)$language_id . "', name = '" . $this->db->escape($r_opt_description['name']) . "'");
				}
			}
		}

вроде ошибка пока пропала, но есть проблема в другом, когда начинаю сохранять новые комплекты, он их не сохраняет.

появился еще 1 баг, причем странный, я пробую починить модуль на тестовом домене dev.***, и такой же модуль стоит на основном. 

Баг заключается в том, что когда я сохраняю данные на тестовом домене, а потом я сохраняю данные(другие) на основном, на основной почему-то перекидываются данные из тестового, я вообще не понимаю как так происходит. базы данных разные, даже префиксы таблиц другие, у меня вообще идей нет

Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.