Перейти к содержанию
reeditor

Не работает Seo-title и Seo-h1 для товаров

Рекомендуемые сообщения

Здравствуйте. Проблема такая: добавил Title и H1 в ocStore, делал все по инструкции на Ассембле. В итоге, поля Seo-Title и Seo-H1 добавились в админке, но Title меняется только у категорий, для товаров он по прежнему берется из названия. Перерыл весь форум (у многих были похожие проблемы) но решение так и не нашел. Прошу вашей помощи.

UPD. Возможно это из-за нестандартного product.tpl, хотя title, по идее, прописывается в header'e.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не замечал таких проблем на ocstore, по крайней мере в 1,5,1,3 и выше все и по стандарту работает на ура, без каких либо дописываний...Обратите внимание на пост с указанного вами сайта (12,2011), явно описывалась какаянить старая версия

какая версия магазина у вас?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не замечал таких проблем на ocstore, по крайней мере в 1,5,1,3 и выше все и по стандарту работает на ура, без каких либо дописываний...Обратите внимание на пост с указанного вами сайта (12,2011), явно описывалась какаянить старая версия

какая версия магазина у вас?

ocStore 1.0.1 там ни Тайтлов ни H1 не было по умолчанию, поэтому я и решил их добавить. Да, я пробовал в ocStore 1.5.1.3 - все работает. У меня тоже работает везде, кроме страниц товаров. Подозреваю, что виноват product.tpl, хотя там вроде все прописано.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

к сожалению с Вашей версией не знаком

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1.5.1.3 не сильно отличается от 1.0.1. Суть там одинакова, самое странное, что title в категориях и производителях работает, а в товаре - нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте. Проблема такая: добавил Title и H1 в ocStore, делал все по инструкции на Ассембле. В итоге, поля Seo-Title и Seo-H1 добавились в админке, но Title меняется только у категорий, для товаров он по прежнему берется из названия. Перерыл весь форум (у многих были похожие проблемы) но решение так и не нашел. Прошу вашей помощи.

UPD. Возможно это из-за нестандартного product.tpl, хотя title, по идее, прописывается в header'e.

 

Нашли решение? У меня, например, не изменяются Title и H1 в заголовке категории товара, а вот в товавре все нормально встало.

   Пока не нашел какая фунция была удалена мной в PHP, но уже понятно то что это где-то в category.tpl

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.