Перейти к содержанию

Рекомендуемые сообщения

Добрый день, великое сообщество опенкартовцев.

У меня такая проблема:

1. Купил сертификат SSL у хостера.

2. Поставил в админке сайта (cPanel)

3. включил в админке SSl

4. переименовал HTTP в HTTPS в файлах config.php

5. SSL заработал. Есть безопасный вход в админку и при заказе, и регистрации/входе в личный кабинет.

6. Пропали изображения в админке и при входе.

Есть решение:

Also, if you get errors that say something about “unsecured content” then somewhere on your page you have a hardcoded url to images, CSS files, or other content of “http.” To solve, view the source on the page where you are receiving the error and search for “http”. You’ll notice that most are “https”. Fix all the occurrences that are not “https”.

ПЕРЕВОД:

Кроме того, если вы получаете ошибки, которые говорят что-то о «необеспеченных содержанию", то где-то на вашей странице у вас есть жестко URL для изображений, CSS файлы, или другое содержание "HTTP". Чтобы решить, просматривать источник на страницу, где вы находитесь получив ошибку и поиск "HTTP". Вы заметите, что большинство из них "HTTPS". Исправить все вхождения, которые не являются "HTTPS".

Подскажите, пожалуйста, в каких файлах теперь настроить изображения?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

UPD настройка фаила .htaccess ничего не дала.

Есть ветка форума на буржуйском сайте, где такая же проблема. Но она не решена.

Вот текст проблемы:

When I have my SSL turned on, it works, but the image manager stops working.

Any ideas on this?

http://forum.opencart.com/viewtopic.php?t=58025

Прошу, помогите, кто сможет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Столкнулся с такой же проблемой

так и не решена?

причем картинки не выводятся и на фронте - при оформлении заказа

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

устранял проблему в частном порядке после анализа ситуации и настроек :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

устранял проблему в частном порядке после анализа ситуации и настроек :-)

 

а можно чуть подробнее?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

оплачивается почасовой анализ и поиск решения.

у вас причины могут быть совершенно другие.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.