Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Отвалились родные "Статьи" на 2.3.0.2.4


Recommended Posts

Добрый день. В админке на ocStore 2.3.0.2.4 перестал работать раздел "Статьи". В него можно зайти через "Каталог->Статьи", видно список статей, но открыть, отредактировать, создать новую нельзя, при попытке любого этого действия открывается пустая страница. При этом генерируется правильная ссылка с верным токеном. Единственное, что можно сделать, это удалить статью. Журнал ошибок пустой. Права просмотра/редактирования в группе пользователей выданы. Абсолютно все остальные функции магазина работают исправно. Установлен шаблон mmkr2, newsblog и настроен ssl. Больше ничего на сайте не делал, как статьи отвалились, ума не приложу. Подскажите, как можно решить проблему без переустановки магазина с нуля?

Link to post
Share on other sites

28 минут назад, herohero сказал:

открывается пустая страница

Как уже писал в другой теме - ищите серверный лог, в нём написано с чем у вас проблема. Если магазин на хостинге, то можете попросить у поддержки чтобы они подсказали вам где находится лог.

Link to post
Share on other sites

4 минуты назад, iglin сказал:

Как уже писал в другой теме - ищите серверный лог, в нём написано с чем у вас проблема. Если магазин на хостинге, то можете попросить у поддержки чтобы они подсказали вам где находится лог.

В панели ISP логи с ошибками также пустые.

Link to post
Share on other sites

8 минут назад, herohero сказал:

В панели ISP логи с ошибками также пустые.

Нужны логи апача или энжиникса, или ещё что там у вас я не знаю. 

Link to post
Share on other sites

1 час назад, iglin сказал:

Нужны логи апача или энжиникса, или ещё что там у вас я не знаю. 

В саппорте ответили : "У вас заказ shared хостинга, никакого доступа к nginx и apache у пользователя нет."
В панели ISP доступны логи access и error. Error пуст. В access с момент входа в админку до попытки добавить новую статью следующее :

[22/Apr/2021:16:46:30 +0300] "POST /admin/index.php?route=common/login HTTP/1.0" 301 - "https://*****.ru/admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "POST /admin/index.php?route=common/login HTTP/2.0" 301 0 "https://*****.ru/admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/1.0" 200 36325 "https://*****.ru/admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/2.0" 200 36325 "https://*****.ru/admin/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=extension/dashboard/chart/chart&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG&range=month HTTP/1.0" 200 935 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=extension/dashboard/chart/chart&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG&range=month HTTP/2.0" 200 935 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=extension/dashboard/map/map&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/1.0" 200 2 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:46:31 +0300] "GET /admin/index.php?route=extension/dashboard/map/map&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/2.0" 200 2 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:47:06 +0300] "GET /admin/index.php?route=catalog/information&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/1.0" 200 32433 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:47:06 +0300] "GET /admin/index.php?route=catalog/information&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/2.0" 200 32433 "https://*****.ru/admin/index.php?route=common/dashboard&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:47:51 +0300] "GET /admin/index.php?route=catalog/information/add&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/1.0" 200 - "https://*****.ru/admin/index.php?route=catalog/information&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"
[22/Apr/2021:16:47:51 +0300] "GET /admin/index.php?route=catalog/information/add&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG HTTP/2.0" 200 0 "https://*****.ru/admin/index.php?route=catalog/information&token=hPz3tMVivOPiwFqbjMhmnYHBEEzUImCG" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36"

 

Link to post
Share on other sites

51 минуту назад, herohero сказал:

information/add

Ну да, так вот видно что ошибки нету, страница возвращается со статусом 200. Но по какой причине на ней пусто не знаю... Наверное только по месту смотреть, разбираться.

Link to post
Share on other sites

Posted (edited)
57 минут назад, iglin сказал:

Ну да, так вот видно что ошибки нету, страница возвращается со статусом 200. Но по какой причине на ней пусто не знаю... Наверное только по месту смотреть, разбираться.

Наверное, проще будет просто с нуля все поставить, благо не много работы проведено.

Тему можно закрыть.

Edited by herohero
Link to post
Share on other sites

49 минут назад, herohero сказал:

Наверное, проще будет просто с нуля все поставить, благо не много работы проведено.

Можно попробовать перезалить только файлы которые отвечают за статьи.

Потом поискать может какие то модификаторы их меняют.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.