Перейти к содержанию
mstdmstd

установка opencart-а потребовала наличие gd

Рекомендуемые сообщения

Всем привет,

Устанавливая opencart-1.5.5.1 на ALT Linux 6.0.2 KDesktop (Centaurea Sadleriana)

установка opencart-а потребовала наличие библиотеки gd.

Warning: GD extension needs to be loaded for OpenCart to work!

У меня установлена libgd2 и она не прокатывает...

И насколько я помню gd это старая либа (была вытеснена gd2 много лет назад) и в репозитории ее судя по всему нет...

opencart-у нужна gd именно первой версии ? Ставить gd из исходников при утсновленной libgd2 кажется геморойно...

залезть в инсталлятор и убрать эту проверку дело не долгое, а дальше проблем не будет ?

Как это побороть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Библиотека GD нужна для масштабирования картинок при создании миниатюр. Без нее картинок не будет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость brk

extension=php_gd2.dll

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

речь о расширении php - php5-gd, а не системной библиотеке.

apt-get install php5-gd

или, что там у вас в ALT Linux из пакетных менеджеров?

/etc/php5/conf.d/gd.ini

; configuration for php GD module
extension=gd.so

###

root@local:/etc/php5/apache2/conf.d# dpkg -l | grep php5-gd
ii  php5-gd							  5.3.3-7+squeeze3				  GD module for php5

Изменено пользователем afwollis

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.