Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Письма из OpenCart в СПАМ


kiwa
 Share

Recommended Posts

Добрый день!

Эта тема неоднократно поднималась на различных форумах но нигде нет ответа на мой вопрос.

Все письма, которые идут из сайта, (инфо о заказе, рассылка новостей) попадают в спам.

Клиенты не догадаются туда заглянуть и это большая проблема.

Коротко о моих настройках:

Почта зарегистрирована на gmail, пока ещё бесплатно было,

в настройках сайта стоит:

Почтовый протокол: MAIL

SMTP хост: ssl://smtp.gmail.com

SMTP логин: [email protected]

SMTP пароль:

SMTP порт: 465

MX-ы прописаны на gmail , от и логин совпадают.

Как сделать так чтобы почта не попадала в спам ?

Link to comment
Share on other sites


клиенты на каком почтовом сервисе?

почему SMTP, а не отправляете почту с хоста через mail()?

не выспался...

протокол у вас указан MAIL, т.е. почту вы как раз отправляете штатными средствами на вашем хостинге - php mail().

информации о том, почему почтовые серверы не доверяют письмам от адреса [email protected], отправленным с хоста yyy.yy, в интернете полно.

в случае smtp письма отправляются не с сайта, а с сервера почтового сервиса.

так что измените протокол на smtp и проверяйте отправку.

Edited by afwollis
  • +1 1
Link to comment
Share on other sites

клиенты на каком почтовом сервисе?

почему SMTP, а не отправляете почту с хоста через mail()?

не выспался...

протокол у вас указан MAIL, т.е. почту вы как раз отправляете штатными средствами на вашем хостинге - php mail().

информации о том, почему почтовые серверы не доверяют письмам от адреса [email protected], отправленным с хоста yyy.yy, в интернете полно.

в случае smtp письма отправляются не с сайта, а с сервера почтового сервиса.

так что измените протокол на smtp и проверяйте отправку.

Пробую

Link to comment
Share on other sites


так что измените протокол на smtp и проверяйте отправку.

При изменении на SMTP почта перестала работать, видимо введённые настройки сервера/логина/пароля/порта не верны

Возможно дело в SSL и 465 порте ?

Есть у кого опыт гугловских настроек ?

осторе 1.5.3.1

post-22198-0-84683000-1359803366_thumb.png

Link to comment
Share on other sites


отправка через гугл SSL решена в новой версии опенкарт 1.5.4.1 но появился следующий вопрос, как обновить только нужную мне функцию, а не весь опенкарт? уже много изменений было сделано...

Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.