Jump to content
Sign in to follow this  
Flint2000

Нету описания в Производителях

Recommended Posts

Сегодня обнаружил проблему. К каждому Производителю добавляю описание, но при переходе на страницу производителя видно только перечень товаров, а самого описания нету. Может я что-то не так делаю? Кеш чистил

Share this post


Link to post
Share on other sites

Что, никто так и не знает в чем трабла?

Share this post


Link to post
Share on other sites

версия движка?

используемый шаблон?

вносили изменения в шаблон вывода производителей?

Share this post


Link to post
Share on other sites

Оссторе 1.5.4.1

Шаблон не стандартный, Technics_for_live

Изменения не вносил, т.к. не знал что нужно. Я думал что если есть в админке возможность добавить описание производителя, то соответственно оно будет показано на странице производителя

Share this post


Link to post
Share on other sites

ссылку на demo шаблона и ваш сайт.

Share this post


Link to post
Share on other sites

так же проблема

та же версия

выслал в личку

Share this post


Link to post
Share on other sites

Решение нашел. Оказывается в моей теме не было куска кода вывода описания

Нужно в файле template/product/manufacturer_info.tpl

добавить это если нету

<?php if ($description) { ?>
 <div class="manufacturer-info"><?php echo $description; ?></div>
 <?php } ?>
 <?php } else { ?>
 <div class="content"><?php echo $text_empty; ?></div>
 <div class="buttons">
   <div class="right"><a href="<?php echo $continue; ?>" class="button"><?php echo $button_continue; ?></a></div>
 </div>
 <?php }?>

Share this post


Link to post
Share on other sites

Решение нашел. Оказывается в моей теме не было куска кода вывода описания

Нужно в файле template/product/manufacturer_info.tpl

добавить это если нету

<?php if ($description) { ?>
 <div class="manufacturer-info"><?php echo $description; ?></div>
 <?php } ?>
 <?php } else { ?>
 <div class="content"><?php echo $text_empty; ?></div>
 <div class="buttons">
<div class="right"><a href="<?php echo $continue; ?>" class="button"><?php echo $button_continue; ?></a></div>
 </div>
 <?php }?>

вставил - ругается на эту строчку

 <?php } else { ?>

Parse error: syntax error, unexpected '}' in /home/domain/../../product/manufacturer_info.tpl on line 204

Share this post


Link to post
Share on other sites

Я привел кусок кода какого не хватает. А синтаксис нужно уже соблюдать исходя из самого шаблона

Share this post


Link to post
Share on other sites

Вроде исправил но теперь выдает

Notice: Undefined variable: description in

я не программист, но я так понимаю что это уже не синтаксис, а не описана переменная?

Share this post


Link to post
Share on other sites

Ну почти, ее просто нету, она до этого нигде не создана

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.