Перейти к содержанию
fantasm

проблема с homeslideshow

Рекомендуемые сообщения

возникла вот такая проблема....

установил модуль home slide show... скачал с офф сайта...

сделал все как описано в readme , ошибок по ходу установки не было, но когда я пытаюсь создать новый слайд не могу выбрать картинку (показано на картинке ниже)...

помогите разобраться... заранее вам благодарен....;)

post-4349-0-87103800-1295778435_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вот ещё:

ocStore Version 0.1.6

П.С. такой ещё моментик... в readme сказанно

MOD:

catalog\view\theme\default\template\common\home.tpl;

add

<div id="column_middle_top">

<?php foreach ($modules2 as $module) { ?>

<?php echo ${$module['code']}; ?>

<?php } ?>

</div>

before

<?php if ($welcome) { ?>

<div class="top">

<div class="left"></div>

<div class="right"></div>

<div class="center">

<h1><?php echo $heading_title; ?></h1>

</div>

но открыв свой home.tpl я обнаружил что у меня немного по другому, и установил код следующим образом:

<div id="content">

<?php if ($welcome) { ?>

<div class="top">

<div class="left"></div>

<div class="right"></div>

<div class="center">

<h1><?php $hwords = explode(" ",$heading_title);

for($j=0;$j<sizeof($hwords);$j++) {if($j%2==0) $hwords[$j] = "<span>".$hwords[$j]."</span>";}

$resultat1 = implode(" ",$hwords);

echo $resultat1;

?>

</h1>

</div>

<div id="column_middle_top">

<?php foreach ($modules2 as $module) { ?>

<?php echo ${$module['code']}; ?>

<?php } ?>

</div>

не знаю если это важно...)))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Похоже у вас проблемы с Менеджером Изображений, как таковым.

Либо правами на папки и/или файлы

homeslidesh...(что тут дальше - догадываюсь, но не вижу)
slide

насчет вставки кода:

<div id="column_middle_top">
<?php foreach ($modules2 as $module) { ?>
<?php echo ${$module['code']}; ?>
<?php } ?>
</div>

<div id="content">
<?php if ($welcome) { ?>
<div class="top">
<div class="left"></div>
<div class="right"></div>
<div class="center">
<h1><?php $hwords = explode(" ",$heading_title);
for($j=0;$j<sizeof($hwords);$j++) {if($j%2==0) $hwords[$j] = "<span>".$hwords[$j]."</span>";}
$resultat1 = implode(" ",$hwords);
echo $resultat1;
?>
</h1>
</div>
Изменено пользователем afwollis

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Похоже у вас проблемы с Менеджером Изображений, как таковым.

Либо правами на папки и/или файлы

на счет прав на папки не думаю, так как сайт на локалхосте... :rolleyes: планирую к 1 числу запустить, вот и дорабатываю..__))

код вставил правильно...ничего не изменилось(

Изменено пользователем afwollis

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Шаблоны к файломенеджеру отношения не имеют.

Проблема либо в самом скрипте, либо в правах на файлы/папки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Шаблоны к файломенеджеру отношения не имеют.

Проблема либо в самом скрипте, либо в правах на файлы/папки.

не думаю что есть проблемы со скриптом, так как скачивал его с офф сайта....на счет прав на папки... ну я не знаю как их установить на localhost и реально ли это вообще...??!!

какие ещё идеи будут?? ну очень нужно поставить слайд-шоу.... может другой модуль подскажите?!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нашел проблему ...картинки отображаются ниже в окне выбора картинок...как исправить это???

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нашел проблему ...картинки отображаются ниже в окне выбора картинок...как исправить это???

Это не такая уж и проблема=) Исправляется элементарно: admin/view/template/module/homepageslideshow.tpl ищешь width: 700, меняешь на width: 1000;

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Это не такая уж и проблема=)

ну может и не проблема...но как-то не приятно было установить всё правильно и в упор не видеть свои слайды... :rolleyes: :unsure:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

проблема с данным моделем.

отображаются рисуноки не в в том разрешении что я указал в админке 300х500 а реальные большие размеры

в чем проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кстати да - у меня также работало.

Я не стал разбираться, ибо небыло желания возиться с ним.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

все сделал как в инструкции но на главной странице в блоке где должен появляться слайдшоу вылазиет ошибка

Unknown: Function split() is deprecated in /home/u276482/shop.xn----7sbbe6af1b3ada4a3a5c.xn--p1ai/www/22/catalog/view/theme/default/template/module/homepageslideshow.tpl on line 30 Unknown: Function split() is deprecated in /home/u276482/shop.xn----7sbbe6af1b3ada4a3a5c.xn--p1ai/www/22/catalog/view/theme/default/template/module/homepageslideshow.tpl on line 30

открыл файл homepageslideshow.tpl on line 30

$img_arr = split("[/.]",$slide_image['file']);

в чем проблема немогу понять

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сам долго мцчался с этой проблемой, но всеже нарыл решение!

Начиная с версии php 5.3.0 и выше все функции для работы с паттернами регулярных выражений должны иметь приставку preg_*, то есть вместо split() теперь должно быть preg_split().

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А как решит проблему-то с размерами фоток, не охота каждый раз вручную их править!

Щас понял, что указывается размер самого окна слайдов, но картинка сама не уменьшается под него.

Ещё проблема с расположением, вместо Middle Top модуль располагается в левом нижнем углу!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

возникла вот такая проблема....

установил модуль home slide show... скачал с офф сайта...

сделал все как описано в readme , ошибок по ходу установки не было, но когда я пытаюсь создать новый слайд не могу выбрать картинку (показано на картинке ниже)...

помогите разобраться... заранее вам благодарен....;)

<?php echo $header; ?><?php echo $column_left; ?><?php echo $column_right; ?>

<div id="content">

<?php if ($welcome) { ?>

<div class="top">

<div class="left"></div>

<div class="right"></div>

<div class="center">

<h1><?php echo $heading_title; ?></h1>

</div>

</div>

<div class="middle">

<div><?php echo $welcome; ?></div>

</div>

<div class="bottom">

<div class="left"></div>

<div class="right"></div>

<div class="center"></div>

</div>

<?php } ?>

<?php foreach ($modules as $module) { ?>

<?php echo ${$module['code']}; ?>

<?php } ?>

</div>

<?php echo $footer; ?>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

<?php echo $header; ?><?php echo $column_left; ?><?php echo $column_right; ?>

<div id="content">

<?php if ($welcome) { ?>

<div class="top">

<div class="left"></div>

<div class="right"></div>

<div class="center">

<h1><?php echo $heading_title; ?></h1>

</div>

</div>

<div class="middle">

<div><?php echo $welcome; ?></div>

</div>

<div class="bottom">

<div class="left"></div>

<div class="right"></div>

<div class="center"></div>

</div>

<?php } ?>

<?php foreach ($modules as $module) { ?>

<?php echo ${$module['code']}; ?>

<?php } ?>

</div>

<?php echo $footer; ?>

у меня вобше такой скрипт !

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

возникла вот такая проблема....

установил модуль home slide show... скачал с офф сайта...

сделал все как описано в readme , ошибок по ходу установки не было, но когда я пытаюсь создать новый слайд не могу выбрать картинку (показано на картинке ниже)...

помогите разобраться... заранее вам благодарен....;)

есле получилось поделись !

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

возникла вот такая проблема....

установил модуль home slide show... скачал с офф сайта...

сделал все как описано в readme , ошибок по ходу установки не было, но когда я пытаюсь создать новый слайд не могу выбрать картинку (показано на картинке ниже)...

помогите разобраться... заранее вам благодарен....;)

есле настройш скинеш лописание ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.