Jump to content

Recommended Posts

Здравствуйте! 
Достался магазин на поддержку на OCStore 2.3.0.2.3. Раньше с данным продуктом я дела не имел. 
Проблема: при смене шаблона появляются битые ссылки на файлы предыдущего шаблона. например такие: 
Notice: Error: Could not load template /home/h/host12dh/sonrais/public_html/catalog/view/theme/default/template/revolution/revsubscribe.tpl! in /home/h/host12dh/sonrais/public_html/system/storage/modification/system/library/template/php.php on line 23
 

Я загружал три разных шаблона, и со всеми проблема повторяется. т.е. нет такого что что-то недогрузил.
На локальном сервере со свежей OCStore всё устанавливается без проблем.
Получается, шаблон revolution сделал невозможным установку других шаблонов? Где его могли так сконфигурировать? Что здесь делать?
Спасибо.

 

Share this post


Link to post
Share on other sites

Обновить модификаторы и удалять кеш на сайте и в браузере пробовали?

Share this post


Link to post
Share on other sites

На кнопку "обновить" в менеджере дополнений нажимал.
Это же действие удаляет кеш модификаторов?

 

Share this post


Link to post
Share on other sites
1 час назад, fathergorry сказал:

Notice: Error: Could not load template /home/h/host12dh/sonrais/public_html/catalog/view/theme/default/template/revolution/revsubscribe.tpl! in /home/h/host12dh/sonrais/public_html/system/storage/modification/system/library/template/php.php on line 23

Отключите все модули старого шаблона. Так как в новом их нет. Ошибка обозначает, что не может найти файл для вывода модуля.

Тоесть, в Вашем новом шаблоне, нет этого файла и система, по-умолчанию, пробудет его открыть с дефолтной папки шаблона.

Share this post


Link to post
Share on other sites
44 минуты назад, OCappLab сказал:

Отключите все модули старого шаблона. Так как в новом их нет. Ошибка обозначает, что не может найти файл для вывода модуля.

Тоесть, в Вашем новом шаблоне, нет этого файла и система, по-умолчанию, пробудет его открыть с дефолтной папки шаблона.

В списке модулей нашел четыре модуля этого шаблона. Установлен только один, но у него в настройках - "отключен". Может, его следует удалить. нажав на кнопку "удалить"?

 

 

Share this post


Link to post
Share on other sites
3 минуты назад, fathergorry сказал:

В списке модулей нашел четыре модуля этого шаблона. Установлен только один, но у него в настройках - "отключен". Может, его следует удалить. нажав на кнопку "удалить"?

 

 

Да, попробуйте, если он Вам не нужен

Share this post


Link to post
Share on other sites

1) Установил новый шаблон на локалке - работает
2) Тем же способом загрузил его на сервер, проставил права админу, включил шаблон, назначил его в настройках сайта - вылезает ошибка 
Notice: Error: Could not load template /home/h/host12dh/sonrais/public_html/catalog/view/theme/default/template/revolution/revslideshow.tpl! in /home/h/host12dh/sonrais/public_html/system/storage/modification/system/library/template/php.php on line 23
3) Удалил все модули, связанные с шаблоном - та же ошибка
4) сменил новому шаблону директорию по умолчанию на директорию старого шаблона - та же ошибка

5) Включил и вернул в настройках старый шаблон - новая ошибка: ошибка 500 без подробностей вывода. (error_log почему-то не пишется. хотя включен) . Но это уже другая проблема, она меня не интересует.

 

 

Share this post


Link to post
Share on other sites
47 минут назад, fathergorry сказал:

1) Установил новый шаблон на локалке - работает
2) Тем же способом загрузил его на сервер, проставил права админу, включил шаблон, назначил его в настройках сайта - вылезает ошибка 
Notice: Error: Could not load template /home/h/host12dh/sonrais/public_html/catalog/view/theme/default/template/revolution/revslideshow.tpl! in /home/h/host12dh/sonrais/public_html/system/storage/modification/system/library/template/php.php on line 23
3) Удалил все модули, связанные с шаблоном - та же ошибка
4) сменил новому шаблону директорию по умолчанию на директорию старого шаблона - та же ошибка

5) Включил и вернул в настройках старый шаблон - новая ошибка: ошибка 500 без подробностей вывода. (error_log почему-то не пишется. хотя включен) . Но это уже другая проблема, она меня не интересует.

 

 

Пишите в ЛС. Будем разбираться.

Share this post


Link to post
Share on other sites

Спасибо, вопрос решен путем увольнения меня)) Доступа больше нет, так что разобраться не получится. 
 

Share this post


Link to post
Share on other sites
1 час назад, fathergorry сказал:

Доступа больше нет, так что разобраться не получится

Для себя попробуйте восстановить такую задачу на локалке. И все таки понять, что и как удалять. Лишним для Вас не будет.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.