Перейти к содержанию
infosait

После переноса сайта на openserver выдает ошибку

Рекомендуемые сообщения

перенес магазин из хостинга на локальный сервер openserver. импортировал базу данных, прописал пути в config.php но все равно пишет ошибку: Fatal error: Call to undefined function start() in D:\localserver\OSPanel\domains\avtofranc.tk\index.php on line 19

 

скриншоты прилагаю. помогите кто знает что я не так делаю

44.jpg

4444.jpg

5656.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Что за index.php такой у 2.3.0.2.3?

 

В оригинале такой:

// Version
define('VERSION', '2.3.0.2.3');

// Configuration
if (is_file('config.php')) {
	require_once('config.php');
}

// Install
if (!defined('DIR_APPLICATION')) {
	header('Location: install/index.php');
	exit;
}

// Startup
require_once(DIR_SYSTEM . 'startup.php');

start('catalog');

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
34 minutes ago, efremovav said:

Что за index.php такой у 2.3.0.2.3?

 

В оригинале такой:


// Version
define('VERSION', '2.3.0.2.3');

// Configuration
if (is_file('config.php')) {
	require_once('config.php');
}

// Install
if (!defined('DIR_APPLICATION')) {
	header('Location: install/index.php');
	exit;
}

// Startup
require_once(DIR_SYSTEM . 'startup.php');

start('catalog');

 

Quote

изменил содержание, но теперь такая ошибка:

 

54545.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, infosait сказал:

 

54545.jpg

Так до бесконечности можно ошибки исправлять. В конфигах указывается HTTP_SERVER - адрес сайта, а не путь к корню.

Скажите, для чего вы затеяли перенос сайта на локальный сервер?

 

Магазин, видимо, перепилен - попробуйте вернуть index.php как было, и нормально прописать HTTP_SERVER и HTTP_CATALOG в конфигах.

Изменено пользователем efremovav
  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
44 minutes ago, efremovav said:

Что за index.php такой у 2.3.0.2.3?

 

В оригинале такой:


// Version
define('VERSION', '2.3.0.2.3');

// Configuration
if (is_file('config.php')) {
	require_once('config.php');
}

// Install
if (!defined('DIR_APPLICATION')) {
	header('Location: install/index.php');
	exit;
}

// Startup
require_once(DIR_SYSTEM . 'startup.php');

start('catalog');

 

Quote

просто у меня стоит шаблон revolution а движок не чистий ocstore. Наверно из за этого проблемы. нужно перенести на локальный, так как интернета ингда нет а товары с ценами нужно смотреть

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 hour ago, infosait said:

 

сейчас сделал так: установил чистый ocstore на домен avtofranc.loc все запустилось. зашел на другой домен avtofranc.tk взял оттуда папку шаблона и скопировал его с заменой на установлеый чистый ocstore. вот что получилось:

 

Изменено пользователем infosait

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если сайт в том виде, в котором вы его перенесли, работает на основном сервере - должен работать и на локальном. Только нужно правильно прописать конфиги.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×