Перейти к содержанию

Рекомендуемые сообщения

Здравствуйте.

Такая проблема. Хочу создать несколько полей в таблице product.

На хостинге пробовал создавать, все без проблем, как запросом, там и вручную.

На локальном сервере же (в моем случае это OpenServer), при создании поля, вручную, или SQL запросом, выдает ошибку ---> #1067 - Некорректное значение по умолчанию для 'date_available'

 

Вот пример запроса:

ALTER TABLE `oc_product` ADD `poletam` VARCHAR(255) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL AFTER `date_modified`

 

На хостинге срабатывает безотказно, поле создается, на OpenServer`e почему то не хочет.

Как быть, в чем проблема? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Самое интересное, если создать поля через PHP скрипт, при удалении данных полей, та же ошибка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.