Перейти к содержанию
Relaxant

Не вижу текст со своего компьютера, но он есть в HTML :0

Рекомендуемые сообщения

Доброго времени суток!

В Opencart 2.1.0.1 произошла очень странная ошибка...для того, чтобы редактировать товары не вписывая каждый раз IP адрес в API, вычитал на одном из форумов и сделал следующее:

добавляем автоматически IP при логине

/admin/controller/common/login.php

после
if (($this->request->server['REQUEST_METHOD'] == 'POST') && $this->validate()) {
вствляем
$this->load->model('user/api');
$api_info = $this->model_user_api->getApi($this->config->get('config_api_id'));         
$this->model_user_api->addApiIp($api_info['api_id'], $this->request->server['REMOTE_ADDR']);

И после данного кода (а больше ничего не менял/не добавлял) - на фронтенде сайта я перестал видеть текст, но в HTML он есть - причем не вижу только я, со своего компьютера через любые браузеры (IE, Хром, ЯБраузер), в т.ч. и через инкогнито режим, а при просмотре с анонимайзера - всё отлично, текст есть и на других компьютерах (с другим IP) тоже все в порядке.

 

Удалил я данный код (тот что выше), почистил системный кэш опенкарта и кэш модификаторов, затем обновил модификаторы - но проблему не решило.
Полностью Очистил кэши в браузерах (IE,ХРОМ, Ябраузер), в т.ч. и куки - ничего не помогло.
Удалил свой IP из API и обновил API ключ - бесполезно
Причем это касается только фронтэнда...в админке - всё хорошо, текст виден.
Не подскажете как решить данную проблему?:ph34r:

Изменено пользователем Relaxant

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, Relaxant сказал:

Доброго времени суток!

В Opencart 2.1.0.1 произошла очень странная ошибка...для того, чтобы редактировать товары не вписывая каждый раз IP адрес в API, вычитал на одном из форумов и сделал следующее:


добавляем автоматически IP при логине

/admin/controller/common/login.php

после
if (($this->request->server['REQUEST_METHOD'] == 'POST') && $this->validate()) {
вствляем
$this->load->model('user/api');
$api_info = $this->model_user_api->getApi($this->config->get('config_api_id'));         
$this->model_user_api->addApiIp($api_info['api_id'], $this->request->server['REMOTE_ADDR']);

И после данного кода (а больше ничего не менял/не добавлял) - на фронтенде сайта я перестал видеть текст, но в HTML он есть - причем не вижу только я, со своего компьютера через любые браузеры (IE, Хром, ЯБраузер), в т.ч. и через инкогнито режим, а при просмотре с анонимайзера - всё отлично, текст есть и на других компьютерах (с другим IP) тоже все в порядке.

 

Удалил я данный код (тот что выше), почистил системный кэш опенкарта и кэш модификаторов, затем обновил модификаторы - но проблему не решило.
Полностью Очистил кэши в браузерах (IE,ХРОМ, Ябраузер), в т.ч. и куки - ничего не помогло.
Удалил свой IP из API и обновил API ключ - бесполезно
Причем это касается только фронтэнда...в админке - всё хорошо, текст виден.
Не подскажете как решить данную проблему?:ph34r:

 

Интернет МТС?

 

У меня такая же проблема. Хостинг IHC

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.