Jump to content

Recommended Posts

Здравствуйте!

Рншил переехать на новый сервак (CentOS 7, OsCtore) ну и решил что пора сайт перевезти на FastCGI (Nginx + PHP-FPM). Сервак поднялся, все сервисы через ISP поставились, сайт перенес. Как было раньше на апаче все взлетело сразу, перевожу на FastCGI (Nginx + PHP-FPM), главная страница открывается и все, больше ни чего :( получаю

404 Not Found nginx/1.8.1

ссылка для примера http://prof-66.fvds.ru/about_us

ЧПУ естественно включено

Как эту связку настроить? Весь инет облазил, лекарства так и не нашол. Файл конфигурации nginx создала система сама (приложен).

Помогите плиз, что ему надо прописать чтоб заработало?

 

 

nginx.zip

Share this post


Link to post
Share on other sites

 

Здравствуйте!

Рншил переехать на новый сервак (CentOS 7, OsCtore) ну и решил что пора сайт перевезти на FastCGI (Nginx + PHP-FPM). Сервак поднялся, все сервисы через ISP поставились, сайт перенес. Как было раньше на апаче все взлетело сразу, перевожу на FastCGI (Nginx + PHP-FPM), главная страница открывается и все, больше ни чего :( получаю

404 Not Found nginx/1.8.1

ссылка для примера http://prof-66.fvds.ru/about_us

ЧПУ естественно включено

Как эту связку настроить? Весь инет облазил, лекарства так и не нашол. Файл конфигурации nginx создала система сама (приложен).

Помогите плиз, что ему надо прописать чтоб заработало?

 

 

.htaccess покажи

 

Share this post


Link to post
Share on other sites

.htaccess покажи

А зачем htaccess, nginx же его не понимает

Попробуйте

location / { try_files $uri @opencart; }

location @opencart { rewrite ^/(.+)$ /index.php?_route_=$1 last; }

location ~ /\.ht { deny all; }

location ~* (\.(tpl|ini))$ { deny all; }

if (!-e $request_filename) { rewrite ^/(.*)$ /index.php?_route_=$1 last; }

location /admin { index index.php; }

после 

server_name localhost;

Edited by pashast

Share this post


Link to post
Share on other sites

А зачем htaccess, nginx же его не понимает

за тем что если там к апачу обращения например в таком варианте

<IfModule mod_rewrite.c>
..

</IfModule>

то всё валится для nginx

пере направления то работают с него..

а вот всякие кеши сжатия (помоему из за них тож может быть)  эт с конфига

у самого  nginx как FastCGI ни раз сталкивался с 500 из за этого

 

Edited by AWARO

Share this post


Link to post
Share on other sites

после 

server_name localhost;

 

Вставил, перезапустил nginx, аочистил кэш сайта. Ни чего не изменилось :( только главная :(

Share this post


Link to post
Share on other sites

 

после 

server_name localhost;

 

Вставил, перезапустил nginx, аочистил кэш сайта. Ни чего не изменилось :( только главная :(

 

Красавчик!

а теперь запихай в файл .htaccess

с заменой всего в нём на это (если что верни конфиг назад и посмотри)

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
Edited by AWARO

Share this post


Link to post
Share on other sites

вот до сервеные данные в моём конфиге

user www-data;worker_processes  8;

error_log  /var/log/nginx/error.log;
pid        /var/run/nginx.pid;

events {
    worker_connections  1024;
    # multi_accept on;
}

http {
    include       /etc/nginx/mime.types;

    access_log	/var/log/nginx/access.log;

    sendfile        on;
    #tcp_nopush     on;

    #keepalive_timeout  0;
    keepalive_timeout  65;
    tcp_nodelay        on;

    gzip  on;
    gzip_disable "MSIE [1-6]\.(?!.*SV1)";
    gzip_http_version 1.0;
    gzip_min_length  265;
    gzip_proxied     any;
    gzip_vary  on;
    gzip_types  text/plain text/xml application/xml application/x-javascript text/javascript text/css text/json image/x-ico application/pdf image/png image/gif;
    gzip_buffers 16 8k;
    gzip_comp_level  5;

    gzip_static  on;
    gzip_proxied expired no-cache no-store private auth;

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
	include /usr/local/ispmgr/etc/nginx.domain;
	client_max_body_size 150M;
	log_format isp '$bytes_sent $request_length';
    server {

Edited by AWARO

Share this post


Link to post
Share on other sites

Запихал, не помагает, вернул свой (прикреплен), я так понимаю, что .htaccess совсем в этой связке не используется? его хоть совсем удаляешь ни чего не меняется :(

htaccess.zip

Share this post


Link to post
Share on other sites

Запихал, не помагает, вернул свой (прикреплен), я так понимаю, что .htaccess совсем в этой связке не используется? его хоть совсем удаляешь ни чего не меняется :(

а это удаляли??

для nginx это не пашет скорее ломает

## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access plus 1 week"
ExpiresByType image/jpeg "access plus 1 week"
ExpiresByType image/gif "access plus 1 week"
ExpiresByType image/png "access plus 1 week"
ExpiresByType text/css "access plus 1 week"
ExpiresByType application/pdf "access plus 1 week"
ExpiresByType text/x-javascript "access plus 1 week"
ExpiresByType application/x-shockwave-flash "access plus 1 week"
ExpiresByType image/x-icon "access plus 1 week"
ExpiresDefault "access plus 1 week"
</IfModule>
## EXPIRES CACHING ##

<ifModule mod_headers.c>
    Header set Connection keep-alive
</ifModule>
очистите это

файл должен иметь такое название

.htaccess

с точкой в начале( ну если вдруг)

И попробуйте создать сайт на поддомене тестовый с опенкартом

если и новый не заработает то ТП хоста

Edited by AWARO

Share this post


Link to post
Share on other sites
что-то натупил 

DEL

Edited by pashast

Share this post


Link to post
Share on other sites

И да хтацесс не нужен https://www.nginx.com/resources/wiki/start/topics/examples/likeapache-htaccess/

 

You can’t do this. You shouldn’t. If you need .htaccess, you’re probably doing it wrong.

Conclusion¶

Stop using .htaccess. It’s horrible for performance. NGINX is designed to be efficient. Adding something like this destroys that.

Share this post


Link to post
Share on other sites

И да хтацесс не нужен https://www.nginx.com/resources/wiki/start/topics/examples/likeapache-htaccess/

 

You can’t do this. You shouldn’t. If you need .htaccess, you’re probably doing it wrong.

Conclusion¶

Stop using .htaccess. It’s horrible for performance. NGINX is designed to be efficient. Adding something like this destroys that.

вот его весь конфиг

user  apache;
worker_processes  2;

error_log  /var/log/nginx/error.log warn;
pid        /var/run/nginx.pid;


events {
    worker_connections  1024;
}


http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access.log  main;

    sendfile        on;
    #tcp_nopush     on;

    keepalive_timeout  65;

    #gzip  on;

    include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/vhosts/*/*.conf;
server {
        server_name localhost;
 disable_symlinks if_not_owner;
	listen 80;
	include /etc/nginx/vhosts-includes/*.conf;
	location @fallback {
		error_log /dev/null crit;
		proxy_pass http://127.0.0.1:8080;'>http://127.0.0.1:8080;
		proxy_redirect http://127.0.0.1:8080 /;
		proxy_set_header Host $host;
		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_set_header X-Forwarded-Proto $scheme;
		access_log off ;
	}
    }
}

но перенаправлять с .htaccess удобнее (и это работает) чем лезть в конфиг файл

 

Edited by AWARO

Share this post


Link to post
Share on other sites

вот до сервеные данные в моём конфиге

с этой частью не перезагружается у меня :( щас логи гляну

Share this post


Link to post
Share on other sites

7ое это не мой конфиг, уважаемого AWARO

Share this post


Link to post
Share on other sites

с этой частью не перезагружается у меня :( щас логи гляну

так вы не копируйте

а скопировав подставьте свои данные

Ваще я б создал с нуля сайт на поддомене и посмотрел бы что и как

потом пощёл бы пилить тех поддержку хостинга..

 

 

А вот этот момент не знал..

эт что получается его присутствие уже тормоз для nginx??

и все перенаправлялки лучше также в конфиг втюхивать?

Edited by AWARO

Share this post


Link to post
Share on other sites

но перенаправлять с .htaccess удобнее (и это работает) чем лезть в конфиг файл

А как через него перенаправлять? на него система совсем ни как не реагирует :( он у меня естественно с точкой.

Share this post


Link to post
Share on other sites

эт что получается его присутствие уже тормоз для nginx??

и все перенаправлялки лучше также в конфиг втюхивать?

 

Судя по тому что я читал, именно так.

 

А вот как впихать?

Edited by dimmam

Share this post


Link to post
Share on other sites

А как через него перенаправлять? на него система совсем ни как не реагирует :( он у меня естественно с точкой.

Вот такие и подобного рода правила в нём работают

# SEO URL Settings
RewriteEngine On
RewriteBase /

RewriteCond %{HTTP_HOST} ^www\.site\.ru$ [NC]
RewriteRule ^(.*)$ http://site.ru/$1 [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\ HTTP/ 
RewriteRule ^index\.html$ / [R=301,L] 
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/ 
RewriteRule ^index\.php$ / [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.html\ HTTP/ 
RewriteRule ^index\.html$ / [R=301,L]


RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

т.е. с www и т.д.

Edited by AWARO

Share this post


Link to post
Share on other sites

 

эт что получается его присутствие уже тормоз для nginx??

и все перенаправлялки лучше также в конфиг втюхивать?

 

Судя по тому что я читал, именно так.

 

А вот как впихать?

 

хз.. чет мне кажется у вас и с нуля сайт там не запустится..

ток ТП хостинга.. чет там у вас не то с fast cgi

Share this post


Link to post
Share on other sites

Для аппача то у меня все прописано и работает... в этой связке ни как :( как все таки все запихнуть в кофиг по человечески?

Ну и мне кажется что еслиб с fast cgi что то не правильно было, то и главная не открылась бы... наверное..

Тут все дело с ЧПУ опенкартовсим мне кажется.. даже на апаче без перенаправлений не заработает ведь.

Edited by dimmam

Share this post


Link to post
Share on other sites

ISPmanager какой? 4 или 5?

Share this post


Link to post
Share on other sites

ISPmanager какой? 4 или 5?

5ый

Share this post


Link to post
Share on other sites

не знаю
у меня с теми данными в хтасес дохнет
без них норм
всё же попробуйте чистый ocStore
 

Share this post


Link to post
Share on other sites

5ый

http://prof-66.fvds.ru/index.php?route=account/login

http://prof-66.fvds.ru/index.php?route=information/sitemap

http://prof-66.fvds.ru/index.php?route=product/special

http://prof-66.fvds.ru/index.php?route=account/voucher

http://prof-66.fvds.ru/index.php?route=product/manufacturer

сеопро?

попробуйте как его отключить

походу с ЧПУ не то, что то

а по основнному домену работает всё??

Edited by AWARO

Share this post


Link to post
Share on other sites

В 5-й версии ISP настройки www-домена производятся вот тут

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.