Jump to content
Sign in to follow this  
animemia

[Решено] админка не работает

Recommended Posts

не могу зайти в админку. Такое ощущение что jquery не работает, либо вирус может, либо с хостингом что. куда копать? ничего такого не из модулей не ставил что могло так навредить сайту. просто сегодня зашел и увидел такую картину. если библиотеки jquery подключить, чтобы из вне, то кнопка войти работает. но админка такая же белая и пунктов меню нет. http://1000ap.ru/admin/

Share this post


Link to post
Share on other sites

В папке admin в файле config.php правильно определите адреса

Share this post


Link to post
Share on other sites

там ничего не менялось. все ведь работало раньше

Share this post


Link to post
Share on other sites

// DIR
define('DIR_APPLICATION', '/home/u860178224/public_html/catalog/');
define('DIR_SYSTEM', '/home/u860178224/public_html/system/');
define('DIR_DATABASE', '/home/u860178224/public_html/system/database/');
define('DIR_LANGUAGE', '/home/u860178224/public_html/catalog/language/');
define('DIR_TEMPLATE', '/home/u860178224/public_html/catalog/view/theme/');
define('DIR_CONFIG', '/home/u860178224/public_html/system/config/');
define('DIR_IMAGE', '/home/u860178224/public_html/image/');
define('DIR_CACHE', '/home/u860178224/public_html/system/cache/');
define('DIR_DOWNLOAD', '/home/u860178224/public_html/download/');
define('DIR_LOGS', '/home/u860178224/public_html/system/logs/');
 

Share this post


Link to post
Share on other sites

Ага-ага, а ничё, что вместо "/home/u860178224/public_html/catalog/" должно быть "/home/u860178224/public_html/admin/" ? Точно ничего не менялось?

Share this post


Link to post
Share on other sites

теперь сайт не работает. ругается на модуль геолокации (определяет город), модуль этот давно уже стоит, всегда норм было. как тогда могло изменится само? я в этот файл не лазил

Share this post


Link to post
Share on other sites

Блин, так для корневой папки сайта и каталога "admin" используются 2 РАЗНЫХ КОНФИГА

Share this post


Link to post
Share on other sites

точно, вот конфиг из папки admin

 

// DIR
define('DIR_APPLICATION', '/home/u860178224/public_html/admin/');
define('DIR_SYSTEM', '/home/u860178224/public_html/system/');
define('DIR_DATABASE', '/home/u860178224/public_html/system/database/');
define('DIR_LANGUAGE', '/home/u860178224/public_html/admin/language/');
define('DIR_TEMPLATE', '/home/u860178224/public_html/admin/view/template/');
define('DIR_CONFIG', '/home/u860178224/public_html/system/config/');
define('DIR_IMAGE', '/home/u860178224/public_html/image/');
define('DIR_CACHE', '/home/u860178224/public_html/system/cache/');
define('DIR_DOWNLOAD', '/home/u860178224/public_html/download/');
define('DIR_LOGS', '/home/u860178224/public_html/system/logs/');
define('DIR_CATALOG', '/home/u860178224/public_html/catalog/');

Share this post


Link to post
Share on other sites

Ну и? Всё получилось? :)

Share this post


Link to post
Share on other sites

Ну и? Всё получилось? :)

а что должно получиься? я ничего не менял, смотрю на код и вижу что все нормально. но в админку не заходит.

 

немного разобрался, если удалить эти строки, то ничего не происходит. то есть эти билиотеки  у  меня не работают, хотя они на своих местах лежат в папках. их я точно не трогал

<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>

<script type="text/javascript" src="catalog/view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>

Share this post


Link to post
Share on other sites

У меня для вас плохие новости. Если в config.php всё указано верно, то правильные адреса такие - 

<script type="text/javascript" src="view/javascript/jquery/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>

Короче правьте свои конфиги, примерно как я показал выше. Ну а вообще доверьте это дело профессионалу, раз уж  мы тут с Вами беседуем почти 2 часа, а проку нет.

Share this post


Link to post
Share on other sites

вот такая у меня админка. то есть пути к css и т.п неправильные?

post-690383-0-63285600-1432044516_thumb.png

Share this post


Link to post
Share on other sites

все)) зря тему создавал, спасибо за советы. файл header.tpl из корневой папки catalog был оказывается заменен в папку admin. достал из бэкапа старый файл, теперь все норм. можно закрыть тему

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.