Перейти к содержанию

Рекомендуемые сообщения

Помогите решить проблему с шаблоном !!! У меня ocstore_v0.2.2, крутится на локалке (Денвер). Установил шаблон opencartws 2.0, всё работает, но при попытке перейти на главную страницу, войти в кабинет или щелкнуть по любой другой ссылке в хидере, меня выкидывает на localhost/denwer/ ! Причём я перепробовал все три шаблона opencartws, 1.1 и 2.0. Правда в 2.0 при нажатии на поиск на денвер не выбрасывает, открывается окно поиска (пустое). Все боковые модули ведут себя как и положено, то есть можно перемещаться по категориям, зайти в корзину и т.д. В стати так же нормально попадаю. Для проверки создал статью, вписал код ссылок:

p>
	<a href="/index.php?route">Войти</a></p>
<p>
	 </p>
<p>
	<a href="/index.php?route=product/search">Поиск...</a></p>
<p>
	 </p>
<p>
	<a href="/index.php?route=account/account">Кабинет</a></p>
Перехожу по ссылкам и.... опять привет денвер!

Помогите решить проблему!!! Уже и не знаю, с какой стороны подойти... Шаблоны неплохие в целом, резиновые к тому же но.... как всегда в бочке мёда ложка г...а

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну где же Вы, русскоязычное сообщество OpenCart!!!??? Неужели ни кто мне не подскажет в чём тут дело? Поставил OpenCart 1.4.9.3, залил шаблон - то же самое. Установил vertrigoserv вместо денвера, опять поставил чистый OpenCart 1.4.9.3, шаблон и..... оказался на стартовой vertrigoserv! Шаблон генерит неверные ссылки.Магазин лежит тут http://localhost/shop/index.php, если в браузере вбиваешь - переходишь на главную. В настройках магазина прописанно http://localhost/shop/. А шаблон генерит ссылки типа http://localhost/index.php. Почему блин так?

А если вручную в header.tpl меняешь строку

<li><a href="/index.php?route=account/login" ><?php echo $text_login; ?></a></li>
,на
<li><a href="home/index.php?route=account/login" ><?php echo $text_login; ?></a></li>
, конечная ссылка приобретает вид: http://localhost/shop/shop/index.php?route=account/login. Есть у кого нибудь мысли на этот счёт?

Как может быть такое, если я штук 20 шаблонов перепробовал и нис одним такого не было. Значит дело в шаблоне, ну логически. Но админ на этом сайте утверждает, что у него и других всё работает.

HELP!!!! Неужели для людей, которые с нуля пишут сайты это неразрешимая задача? Помогите вы новичку, плиз!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

подозреваю, что дело в .htaccess строчку

RewriteBase /
поменять на
RewriteBase /open/
на хостинге помогло бы, а вот на локалке... пробуй.

еще можно глянуть путь в config.php на предмет наличия /shop.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.